I have a problem with php-fpm

Type: Bitnami Support Tool

Description:
support tool hangs after running
My problem is:
Having WordPress white screen
AH02454: FCGI: attempt to connect to Unix domain socket /opt/bitnami/php/var/run/wordpress.sock

I got a zip file,
The diagnostic bundle file was successfully created, but the automatic upload to Bitnami servers failed. You will need to upload it to your Bitnami Support ticket manually.

where I should upload it?

===== Begin of bndiagnostic tool output =====

Action ‘-t -f /opt/bitnami/apache2/conf/httpd.conf’ failed.
The Apache error log may have more information.

✓ Processes: No issues found
? Apache: Found possible issues
✓ Connectivity: No issues found
✓ Mysql: No issues found
? Resources: Found possible issues
✓ Php: No issues found

[Apache]

Found recent error or warning messages in the Apache error log.

[Sat Jan 08 15:51:17.236832 2022] [proxy:error] [pid 6088:tid 140699345176320]
(2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain
socket /opt/bitnami/php/var/run/wordpress.sock (wordpress-fpm) failed
 [Sat Jan 08 15:51:17.236848 2022] [proxy_fcgi:error] [pid 6088:tid
Press [Enter] to continue:
140699345176320] [client **ip_address**:41638] AH01079: failed to make
connection to backend: httpd-UDS
 [Sat Jan 08 15:53:47.598703 2022] [core:error] [pid 5110:tid 140699929542272]
AH00046: child process 6088 still did not exit, sending a SIGKILL

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/

The Apache configuration has errors:

apache2: Syntax error on line 66 of /opt/bitnami/apache2/conf/httpd.conf: Cannot
load modules/mod_mpm_event.so into server: libiconv.so.2: cannot open shared
object file: No such file or directory

Please check the configuration.

A high number of incoming requests originate from one or more unique IP
addresses. This could indicate a bot attack. The following guide shows how to
check for and block suspicious IP addresses.

Press [Enter] to continue:
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-
bots-apache/

[Resources]

Your instance has little available RAM memory.

 total used free shared buff/cache available Mem: 32179 3524 757 374 27897 27824
Swap: 0 0 0

You could try to increase your instance’s memory. Please check your cloud
provider’s documentation for more information.

You can also enable swap memory to improve performance.

https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-m
emory-linux/

===== End of bndiagnostic tool output =====
Press [Enter] to continue: The diagnostic bundle file was successfully created, but the automatic upload to Bitnami servers failed. You will need to upload it to your Bitnami Support ticket manually. Please locate the following file in your file browser or in your terminal: /tmp/bitnami-wordpress-info-20220108-163223-11435.zip Exercise caution when uploading the resulting diagnostic bundle to public sites as it contains detailed diagnostic information.

Hi @yazzoon,

It seems there is a problem with the different services in the instance, can you check if they all are running right now?

sudo /opt/bitnami/ctlscript.sh status

You can try to start them by using the start option.

Your instance has enough RAM memory and that shouldn’t be the problem. What’s the content of the services’ log files?

sudo tail -n 20 /opt/bitnami/apache2/logs/error_log
sudo tail -n 20 /opt/bitnami/php/var/log/php-fpm.log

Thanks