I don't know where to get SSH key

Keywords: General - Google Cloud Platform - Technical issue - Connectivity (SSH/FTP)
Description:
I follow below guideline to get SSH key , but where I can get the SSH file ?Seems these files exist on server only .
"
If you are using the Google Cloud Launcher, you will need to generate and add your SSH key manually using these instructions.

Generate SSH key pair by executing the following commands:

NOTE: Replace USERNAME in the commands below with your Google Cloud platform username.
sudo su USERNAME
ssh-keygen -t rsa -f ~/.ssh/my-ssh-key -C USERNAME
Enter the passphrase twice. The SSH key pair will be generated and saved in /home/USERNAME/.ssh/my-ssh-key and /home/USERNAME/.ssh/my-ssh-key.pub.

Hi,

If you are using Google Cloud, you must have launched your instance in one of the below ways:

  • Google Cloud Launcher: If you use this option, you can obtain your SSH credentials following this guide.
  • Bitnami Launchpad: In the other hand, if you use this option, you can obtain your SSH credentials following this guide.

Please let us know if this solves the issue.

Best regards,
Carlos R. Hernández

I find the below answer :https://community.bitnami.com/t/project-wide-ssh-keys-for-ssh-tunnel-on-bitnami-lamp-stack-google-cloud-launcher/51671

So clear to use SFTP , tks for all .

Hi!

I just deleted the previous post because share your private key is not a good security practice. About the issue, have you finally found the solution? If not, can you confirm if you’re using Google Cloud Launcher or Bitnami Launchpad?

Best regards,
Carlos R. Hernández

HI @crhernandez , I use Google Cloud Launchpad .Yes , I can get through SFTP via FileZilla , however , the permission for this user is limited , please guide me the command to give full authority for a user .

Hi,

In Linux, every file and folder have owner and permissions. The owner can be split into user and group. As you can see in the last screenshot (last column), for example, the login.php file is owned by the user daemon and the group daemon.

Also, in the permissions column, you can see rw-rw-r--, this is the permissions that the user and the group have in this file.

According to the permissions column, login.php is readable ® and writable (w) by the user and the group:

user group others
rw-   rw-    r--

As we said previously, according to the owner column, this user and group are daemon.

If you are using FileZilla with the bitnami user, this user doesn’t have permissions to write this file. To solve it, we can modify the permissions of the file, for that we can add writable permission to others, this means that other users (not owned, like bitnami user) can write the file.

For doing that, in FileZilla, you can right-click the file and choose ‘File Permissions’ to open the file attributes and click on the ‘write’ checkbox in the ‘Public Permission’ area or insert 666 in the ‘Numeric value’ field.

image

In the same way, you can do it for a folder and if the recursive option is checked it would be applied to the subdirectories and files under this folder.

Best Regards,
Carlos R. Hernández

HI @crhernandez ,
Thank for your clear info .HOwever , when I set the permission for folder :/opt/bitnami/apps/erpnext/htdocs/frappe-bench/sites/erpnext/public/files in order to upload some images , Filezilla still say “set attrs for /opt/bitnami/apps/erpnext/htdocs/frappe-bench/sites/erpnext/public/files: permission denied”


I think that I log in by private key with user " rsa-xxx" so I don;t have right to change permission even for Public Permission.
If my thought is correct, please guide me how to connect with user "bitnami "

Hi,

according to https://docs.bitnami.com/google/faq/#how-to-upload-files-to-the-server-with-sftp you should use bitnami as username. As you can see in your previous screenshot, files folder owner is bitnami.

Please let us know if this solves the issue.

Best regards,
Carlos R. Hernández

HI @crhernandez , I can not log in with user “bitnami” but can log in with user “rsa-xxx”

I use same method with “rsa-xxx” but can not not log in by Filezilla .
Below is the error :“Error: Disconnected: No supported authentication methods available (server sent: publickey)
Error: Could not connect to server”

Hi,

It seems that you don’t edit the SSH key through the Google Admin Console. Can you take a look at https://docs.bitnami.com/google/faq/#obtaining-your-ssh-credentials-from-the-google-cloud-launcher? Please, pay special attention to:

  • Update the user@hostname comment at the end of the SSH key content to bitnami. This will associate the SSH key with the bitnami user account that is already present on the server. The “Username” next to the form field will update accordingly.

https://docs.bitnami.com/images/img/platforms/google/connect-ssh-client-3-a493a8aa.png

After that, you should be able to connect using bitnami user and be able to edit the files with the correct permissions.

Please let us know if this solves the issue.

Best regards,
Carlos R. Hernández

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.