I don't know what i do

Keywords: WordPress - AWS - How to - Connectivity (SSH/FTP)

Description:
I’m trying install the certificate but that code bncert-tool don´t work well , i already update the file but i cant connect
this is code that shows

bitnami@ip-172-31-8-86:~$ sudo /opt/bitnami/bncert-tool
----------------------------------------------------------------------------
Welcome to the Bitnami HTTPS Configuration tool.

----------------------------------------------------------------------------
Bitnami installation directory

Please type a directory that contains a Bitnami installation. The default
installation directory for Linux installers is a directory inside /opt.

Bitnami installation directory [/opt/bitnami]: ----------------------------------------------------------------------------
Welcome to the Bitnami HTTPS Configuration tool.

----------------------------------------------------------------------------
Bitnami installation directory

Please type a directory that contains a Bitnami installation. The default
installation directory for Linux installers is a directory inside /opt.

Bitnami installation directory [/opt/bitnami]:

Warning: The path does not seem to contain a valid Bitnami installation. Make
sure you have proper access rights, or choose a different directory.
Press [Enter] to continue:----------------------------------------------------------------------------
Bitnami installation directory
1 Like

Hello @bernardikassia,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code ID that is shown at the end.

Regards

Hello Bitnami,

I also got exactly the same messages on my newly deployed Prestashop VMs by Bitnami on GCP.

I have a working (Production) VM from Nov. 2021 but it is all working fine. You can see the reference output below on the working VM.

Linux prestashop-1-vm 4.19.0-17-cloud-amd64 #1 SMP Debian 4.19.194-3 (2021-07-18
) x86_64
*** Welcome to the PrestaShop packaged by Bitnami 1.7.8-0-5 *** ***
Last login: Wed Jan 5 06:13:55 2022 from 35.235.240.160
ray_ann_bulala@prestashop-1-vm:~$ sudo /opt/bitnami/bncert-tool

Welcome to the Bitnami HTTPS Configuration tool.

Domains
Please provide a valid space-separated list of domains for which you wish to
configure your web server.
Domain list []:


However, as mentioned, on my newly deployed Linux VMs, it is not working, I have done it many times and tried the answers in the different forums here (e.g. Restarted VM, restart services, diagnostic tool, etc.) but nothing seems to work so far.

Linux prestashop-3-dev3-vm 4.19.0-18-cloud-amd64 #1 SMP Debian 4.19.208-1 (2021-
09-29) x86_64
*** Welcome to the PrestaShop packaged by Bitnami 1.7.8-2-11 ***
***
Last login: Wed Jan 5 06:16:22 2022 from 35.235.240.162
ray_ann_bulala@prestashop-3-dev3-vm:~$ sudo /opt/bitnami/bncert-tool

Welcome to the Bitnami HTTPS Configuration tool.

Bitnami installation directory
Please type a directory that contains a Bitnami installation. The default
installation directory for Linux installers is a directory inside /opt.
Bitnami installation directory []: /opt/bitnami
Warning: The path does not seem to contain a valid Bitnami installation. Make
sure you have proper access rights, or choose a different directory.
Press [Enter] to continue:

Bitnami installation directory
Please type a directory that contains a Bitnami installation. The default
installation directory for Linux installers is a directory inside /opt.
Bitnami installation directory [/opt/bitnami]:


Please help.

Thank you.

Ray

I followed this solution;

Hello @ray.ann.bulala,

We are working on fixing some issues with our support and cert tools. We will let you know once it is fixed.

Regards

1 Like

I also want to report the same issue on JasperReports packaged by Bitnami 7.8.1-15. Deployed in Azure today (1-7-22).

Hi, we have identified the problem reported in the first message of this topic, and released a new version of the bndiagnostic (0.9.17) and bncert (0.7.2) tools with a fix for the errors. If you launch the current version of the tool, it should detect the new version and attempt to download it.

If it doesn’t detect it, you can always download the bncert tool manually:

https://downloads.bitnami.com/files/bncert/0.7.2/bncert-0.7.2-linux-x64.run
md5: 7170b9d68641f5a045a5e6e4b5772a3a

And for bndiagnostic:

https://downloads.bitnami.com/files/bndiagnostic/0.9.17/bndiagnostic-0.9.17-linux-x64.run
md5: e813e84f0fad054e39eba4508157b489

Ok, it took me some time, but in new installations on GCP, Bitnami package (for OpenCart) is still on lower version, I still have to maintain /opt/bitnami/properties.ini with;

[General]
installdir=/opt/bitnami

Then I can launch and update the version of BNCert.

Anyway, it works now, thank you.

Ray

Great @ray.ann.bulala,

You can also download the latest version of the tool by following our documentation

https://docs.bitnami.com/general/how-to/understand-bncert/

There is no /opt/bitnami/properties.ini file for me.
I tried with the new version and i have the same loop wit the warning directory
Help please!

Could you please let me know what Bitnami solution and the version you have? All Bitnami solutions should have the properties.ini file.