I can't update WordPress or plugins throw the control panel

Keywords: WordPress + NGINX + SSL - Google Cloud Platform - Technical issue - Permissions
bnsupport ID: 7f1cf21c-50c5-b1ee-0d7a-a797a30c6f3c
Description:
I have been struggling updating and adding plugins or files to my site using the wordpress control panel.

I already try to follow all the open topics talking about the issue but nothing works.

Thanks in advance.

Hi @jpguerrero,

Can you try to reset the WordPress permissions?

sudo chown -R bitnami:daemon /opt/bitnami/wordpress/
sudo find /opt/bitnami/wordpress/ -type d -exec chmod 775 {} \;
sudo find /opt/bitnami/wordpress/ -type f -exec chmod 664 {} \;
sudo chmod 640 /opt/bitnami/wordpress/wp-config.php

Regards,
Michiel


Please click on :heart: if you think my answer was helpful.


Thanks Michel for your help. I just run them, but the “Destination directory for file streaming does not exist or is not writable” message keeps happening.

Is there anything else I could do?

Thanks in advance.

Hi @jpguerrero,

Could you run the bnsupport tool again so I can check the current permissions?

Regards,
Michiel

Thanks, here is the code f6fdd135-4e7c-3d6d-4501-49acf41a0580

JP

Hi @jpguerrero,

It seems your instance doesn’t have enough RAM available for the application to run smoothly, I recommend upgrading to a more powerful instance:

https://docs.bitnami.com/google/faq/administration/change-server-type/

Regards,
Michiel

Thanks, I just updated the instance (8GB RAM). I still have the same problem, any more ideas?

New code: 0b5b8f27-93c3-12b9-ee16-1aadd4e2e54f

Thanks.

This is the message that I received every time I tried to update something:

Update failed: Download failed. Destination directory for file streaming does not exist or is not writable.

Hi @jpguerrero,

Can you try increasing the PHP memory limit? Currently it’s128M:

https://docs.bitnami.com/ibm/apps/wordpress/configuration/configure-phpfpm-options/

Can you also update the WP_MEMORY_LIMIT in the apps/wordpress/htdocs/wp-config.php file?

And then restart?

sudo /opt/bitnami/ctlscript.sh restart apache

Regards,
Michiel

Thanks, I just updated to 512, we had 256.

In any case, we use Nginx, not Apache. Just so you can take it under consideration, because the problem persist.

Thanks.

Hi @jpguerrero,

Sorry, did you restart Nginx?

sudo /opt/bitnami/ctlscript.sh restart nginx

Can you also check the available RAM?

free -m

Regards,
Michiel

Yep, of course I did restart it.

Let me know if you think of something else.

Thanks.

Hi @jpguerrero

I have been reviewing your wp-config.php configuration and noticed that you have set the WP_TEMP_DIR variable. This variable is intended to determine a writable directory for temporary files. Nevertheless, the folder /temp/ doesn’t seem to exist in /opt/bitnami/apps/wordpress/htdocs/, which will explain why you are obtaining the aforementioned error.

In order to solve this, either create the directory and grant the necessary permissions or remove that line from the file:

/opt/bitnami/apps/wordpress/htdocs/wp-config.php

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
        define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

- define('WP_TEMP_DIR', ABSPATH . '/temp/');

After that, restart Apache and try again:

$ sudo /opt/bitnami/ctlscript.sh restart apache

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Thanks a lot for all the help, this actually solve the issues :slight_smile:

Best regards

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: