I can't get Bitnami Support Tool ID

Type: Bitnami Support Tool

Description:
I run the Support Tool and give me this info:

===== Begin of bndiagnostic tool output =====

? Apache: Found possible issues
✓ Connectivity: No issues found
? Resources: Found possible issues
? Mysql: Found possible issues
? Php: Found possible issues

And all the details and finally ===== End of bndiagnostic tool output =====

Press [Enter] to continue:

Press [Enter] to continue:
The support bundle file was successfully created, but the automatic upload to Bitnami servers failed. You will need to upload it to your Bitnami Support ticket manually. Please locate the following file in your file browser or in your terminal: /tmp/bitnami-magento-info-20210721-083216-19767.zip Exercise caution when uploading the resulting support bundle to public sites as it contains detailed diagnostic information

But I don’t get the ID to open a ticket about a couple of problems that I have on my instance

Can you guys help me, pleas?

Hi @badinmagento,

Thanks for using Bitnami. We will help you to run the bnsupport tool. Can you run the next commands in your server and share the output with us?

sudo df -h
sudo free -m
uptime
sudo /opt/bitnami/ctlscript.sh status

Once you get this information, can you stop the Bitnami services running the next command and run the bnsupport tool again? Let’s see if having less load in your server solves the upload issue

sudo /opt/bitnami/ctlscript.sh stop

Once you have run the tool, start the services again

sudo /opt/bitnami/ctlscript.sh start

Let us know if the upload process worked this time

Thank you for the reply. I follow your guide and I got the same message.

Hi @badinmagento,

Thanks for the info. Can you share the output of the commands I shared (df, free, uptime...)?

Can you also run the bnsupport tool again to get the most recent information? If it fails to upload the file to our servers, please follow the steps in the next guide to manually upload it and share it with us in a private message I’ve just sent you

https://docs.bitnami.com/installer/how-to/understand-bnsupport/#manually-upload-the-bitnami-support-tool-bundle

It would be great if you give us as much information as possible about the issue you are having using the application.

Hi! I did some optimizations and now works.

This is the ID:
d86908aa-c8a4-3082-8673-ced28a580351

And I have this errors:

===== Begin of bndiagnostic tool output =====


? Apache: Found possible issues
✓ Connectivity: No issues found
✓ Resources: No issues found
? Mysql: Found possible issues
? Php: Found possible issues

[Apache]

Found recent error or warning messages in the Apache error log.

[Wed Jul 28 05:39:32.551873 2021] [proxy_fcgi:error] [pid 10334:tid 
140300617942784] [client **ip_address**:17964] AH01071: Got error 'PHP message: 
PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit 
change max_input_vars in php.ini. in Unknown on line 0', referer: 
https://laonda.com.pa/electrodomesticos
 [Wed Jul 28 05:39:43.192145 2021] [proxy_fcgi:error] [pid 12787:tid 
140300794189568] [client **ip_address**:26402] AH01071: Got error 'PHP message: 
Press [Enter] to continue:
PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit 
change max_input_vars in php.ini. in Unknown on line 0', referer: 
https://laonda.com.pa/electrodomesticos?p=2
 [Wed Jul 28 05:40:02.668604 2021] [proxy_fcgi:error] [pid 12787:tid 
140300718655232] [client **ip_address**:40294] AH01071: Got error 'PHP message: 
PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit 
change max_input_vars in php.ini. in Unknown on line 0', referer: 
https://laonda.com.pa/hogar-y-decoracion

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/

A high number of incoming requests originate from one or more unique IP
addresses. This could indicate a bot attack. The following guide shows how to
check for and block suspicious IP addresses.

https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-
bots-apache/

[Mysql]
Press [Enter] to continue:

Found recent error messages in the MySQL error log:

2021-07-22T18:15:10.060517Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 
'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They 
will be merged with strict mode in a future release.

Please check the following guide to troubleshoot MySQL issues:

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-m
ysql/

[Php]

The following error appears in the
/opt/bitnami/php/var/log/php-fpm.log:

[28-Jul-2021 05:52:14] WARNING: [pool www] server reached max_children setting 
(5), consider raising it

This error usually indicates PHP script execution is slow due to busy server
Press [Enter] to continue:
resouces or buggy scripts. Please check the following guide to increase the
number of PHP-FPM child processes:

https://docs.bitnami.com/general/apps/wordpress/configuration/configure-ph
pfpm-processes/

But I the links doesn’t works.
How I can solve this issues?

Thank you.

Hi @badinmagento,

Thanks for the detailed information. Please find my comments in-line

[Wed Jul 28 05:39:32.551873 2021] [proxy_fcgi:error] [pid 10334:tid
140300617942784] [client ip_address:17964] AH01071: Got error ‘PHP message:
PHP Warning: Unknown: Input variables exceeded 1000. To increase the limit
change max_input_vars in php.ini. in Unknown on line 0’, referer:
https://laonda.com.pa/electrodomesticos

According to this message, you need to update the max_input_vars value in php.ini file. I think this issue may be caused by the theme or the plugins you may be using. We recommend you to check with the theme/plugin developers to get an idea of the value needed. Take into account you may need to restart the Bitnami services for changes to take effect

sudo /opt/bitnami/ctlscript.sh restart

A high number of incoming requests originate from one or more unique IP
addresses. This could indicate a bot attack. The following guide shows how to
check for and block suspicious IP addresses.

Please check the provided link to verify if your site is under a bot attack and how to block them

https://docs.bitnami.com/bch/apps/magento/troubleshooting/deny-connections-bots-apache/

2021-07-22T18:15:10.060517Z 0 [Warning] ‘NO_ZERO_DATE’, ‘NO_ZERO_IN_DATE’ and
‘ERROR_FOR_DIVISION_BY_ZERO’ sql modes should be used with strict mode. They
will be merged with strict mode in a future release.

This message from MySQL is just a warning that I think you can disregard.

[28-Jul-2021 05:52:14] WARNING: [pool www] server reached max_children setting
(5), consider raising it

It looks like you are using a big instance, can you update the PHP-FPM values in the /opt/bitnami/php/etc/common-dynamic.conf file and then restart PHP-FPM? You can use the link below to determine the new PHP-FPM values

https://www.kinamo.be/en/support/faq/determining-the-correct-number-of-child-processes-for-php-fpm-on-nginx