I can’t connect to mysql DB

Keywords: WordPress - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: 4c2510ca-9c5e-9b58-8d38-aee1f1b0613c

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/administration/use-pagespeed/#disable-pagespeed
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
Hello, I need to access to mysql DB of my wordpress.
I followed this guideline https://docs.bitnami.com/aws/faq/get-started/access-phpmyadmin/#access-phpmyadmin-on-linux-and-macos 2 and tried to access to mysql with the user “root” and the password received from cat bitnami_application_password but I have this error: mysqli::real_connect(): (HY000/1045): Access denied for user ‘root’@‘localhost’ (using password: YES

Could you please help me with this?

Hi @pedrocabrera,

Can you login manually to MySQL using the same credentials? Can you try?

https://docs.bitnami.com/aws/infrastructure/mysql/get-started/connect-mysql/

Regards,
Michiel

Hi there, thanks for answer my questions.
I tried but also it doesn’t work.
How can I get the correct user and password? I can connect to my wordpress via SFTP, so the bitnami password works, but I don’t know if I have to use the same password and user name “root”
Could you please help me? I have an error that I need to fix asap.
Thank you.

Hi @pedrocabrera,

I recommend resetting the MySQL credentials. The steps are described here:

https://docs.bitnami.com/general/apps/redmine/administration/change-reset-password-mariadb/#reset-the-mariadb-root-password

Regards,
Michiel

Thank you, I have mysql DB no mariaDB. Do you have the same guideline for mySQL?
If I reset the password, should I change also the SFTP password?
Last question: Is there any way I can connect to mysql data base from an IDE? and not from the phpadmin?

Hi @pedrocabrera,

It should also work for MySQL, just replace mariadb with mysql in the commands.

That’s not necessary.

Regards,
Michiel

Thanks you for your answer.
Now, I have the user and password. I would like to see the DB in AWS RDS, would that be possible?
I would need to replicate data from my wordpress DB to a different DB that is also in AWS.

Hi @pedrocabrera,

The following guide explains how you can migrate the DB to RDS:

https://docs.bitnami.com/aws/how-to/migrate-database-rds/

Regards,
Michiel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.