Httpd-prefix.conf file does not exist on Magento 2 intance on AWS

Keywords: Magento - AWS - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: 123e5148-bc61-bc73-f55c-49ee1f51d59a

bndiagnostic output:

The diagnostic tool couldn't find any issues.

bndiagnostic failure reason: The tool could not find any issue

Description:

  • Use Bitnami console to create Magento 2 instance on AWS.
  • Follow documentation here to setup ELB, setup A records etc. (It’s out of current AWS, but easy to figure out)
  • Continue documentation to add lines to the file opt/bitnami/apps/magento/conf/httpd-prefix.conf. Documentation here: https://docs.bitnami.com/aws/how-to/configure-elb-ssl-aws/
  • Note that file does not exist. I also tried doing a find search for similar looking files, and could not find it.

Where should I add these lines now for Magento 2 ? Should I create the files manually?

Requesting assistance in order to proceed - not just with this issue, but also direction on whether the rest of the document is also out of date.

Thanks guys!

Hi @adam12

Thanks for reporting this. That step in the guide seems to be outdated, as those are the paths older versions of the Bitnami Magento stack used. Can you please try adding that line to the following file instead?

/opt/bitnami/apache/conf/vhosts/magento-vhost.conf

+   SetEnvIf x-forwarded-proto https HTTPS=on

<VirtualHost 127.0.0.1:81 _default_:81>
  ServerAlias *
  DocumentRoot /opt/bitnami/magento
  <Directory "/opt/bitnami/magento">
    Options -Indexes +FollowSymLinks -MultiViews
    AllowOverride All
    Require all granted
  </Directory>
</VirtualHost>

Next, for step 5, use the same file again.

Could you please try to follow these steps and report back? I will notify the documentation team to update those steps then :slightly_smiling_face:

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.