Http2 (almost?) impossible in Bitnami Drupal on AWS Lightsail

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?:
    Bitnami Drupal 9.0.3-4

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX):
    AWS Lightsail

  • Have you installed any plugin or modified any configuration file?:

  • Describe here your question/suggestion/issue (expected and actual results):
    I decided not to bother you before, getting lost in many searches on the internet without concluding anything.
    It all started wanting to follow this guide:
    https://docs.bitnami.com/aws/apps/trac/administration/enable-http2-apache/
    Identified approach A, I did what was indicated but the http2 protocol was not indicated anywhere, a clear sign that at least for me this guide did not work at all.
    So I thought about researching the problem in other issues and similar forum discussions and then I did some experiments. What can I say, between installations and uninstallations of apache, nginx, server stop, we end up that now the server can no longer restart, the site is no longer reachable, in the apache log files it appears that port 80 is configured on port 443, not I can understand where or what to do to: first have the site up again and then be able to enable http2.
    It seems nearly impossible to enable http2 in Bitnami Drupal on AWS Lightsail instance (to me).

  • Steps to reproduce the issue (if relevant):
    d862cc71-0a64-d798-f9cc-6592437f2c84

  • Copy the apache log (if relevant):

[Sun Jan 10 00:00:14.901593 2021] [mpm_event:notice] [pid 31324:tid 140652898159488] AH00493: SIGUSR1 received.  Doing graceful restart[Sun Jan 10 00:00:14.984990 2021] [ssl:warn] [pid 31324:tid 140652898159488] AH01916: Init:(it.dimamegroup.com:443) You configured HTTP(80) on the standard HTTPS(443) port![Sun Jan 10 00:00:14.985251 2021] [mpm_event:notice] [pid 31324:tid 140652898159488] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured -- resuming normal operations[Sun Jan 10 00:00:14.985261 2021] [core:notice] [pid 31324:tid 140652898159488] AH00094: Command line: '/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf'[Sun Jan 10 01:47:58.635345 2021] [authz_core:error] [pid 28556:tid 140651941304064] [client 13.92.42.179:61315] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Sun Jan 10 08:40:28.818408 2021] [authz_core:error] [pid 27786:tid 140651924518656] [client 45.155.205.108:40606] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Sun Jan 10 08:40:29.093430 2021] [authz_core:error] [pid 28556:tid 140651932911360] [client 45.155.205.108:41546] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Sun Jan 10 08:43:03.169399 2021] [authz_core:error] [pid 28556:tid 140651857377024] [client 40.121.52.49:47618] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Sun Jan 10 12:45:41.138017 2021] [authz_core:error] [pid 28556:tid 140651731486464] [client 13.92.42.179:57807] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Sun Jan 10 16:52:48.157041 2021] [authz_core:error] [pid 27785:tid 140651958089472] [client 45.155.205.108:48536] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Sun Jan 10 16:52:51.018799 2021] [authz_core:error] [pid 28556:tid 140651823806208] [client 45.155.205.108:36400] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Sun Jan 10 18:41:48.116627 2021] [authz_core:error] [pid 28556:tid 140651739879168] [client 170.39.186.106:60943] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Sun Jan 10 19:20:26.831980 2021] [authz_core:error] [pid 28556:tid 140651714701056] [client 170.39.186.106:51741] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Sun Jan 10 19:44:06.684592 2021] [authz_core:error] [pid 28556:tid 140651622381312] [client 170.39.186.106:57978] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Sun Jan 10 23:04:19.211585 2021] [authz_core:error] [pid 27785:tid 140651723093760] [client 45.155.205.108:42958] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Sun Jan 10 23:04:19.357668 2021] [authz_core:error] [pid 28556:tid 140651899340544] [client 45.155.205.108:57252] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Mon Jan 11 00:00:02.711934 2021] [mpm_event:notice] [pid 31324:tid 140652898159488] AH00493: SIGUSR1 received.  Doing graceful restart[Mon Jan 11 00:00:02.787529 2021] [ssl:warn] [pid 31324:tid 140652898159488] AH01916: Init:(it.dimamegroup.com:443) You configured HTTP(80) on the standard HTTPS(443) port![Mon Jan 11 00:00:02.788814 2021] [mpm_event:notice] [pid 31324:tid 140652898159488] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured -- resuming normal operations[Mon Jan 11 00:00:02.788827 2021] [core:notice] [pid 31324:tid 140652898159488] AH00094: Command line: '/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf'[Mon Jan 11 02:31:07.765653 2021] [authz_core:error] [pid 5895:tid 140651832198912] [client20.197.89.140:63863] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Mon Jan 11 06:10:34.180711 2021] [authz_core:error] [pid 5895:tid 140651588810496] [client52.231.204.102:51108] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Mon Jan 11 10:39:09.703175 2021] [authz_core:error] [pid 5895:tid 140651664344832] [client45.155.205.108:38086] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Mon Jan 11 10:39:10.765940 2021] [authz_core:error] [pid 5434:tid 140651882555136] [client 45.155.205.108:46676] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Mon Jan 11 18:46:26.039758 2021] [authz_core:error] [pid 5434:tid 140651773449984] [client45.155.205.108:57864] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Mon Jan 11 18:46:26.924587 2021] [authz_core:error] [pid 5895:tid 140651605595904] [client45.155.205.108:48026] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Mon Jan 11 22:48:38.204155 2021] [authz_core:error] [pid 5434:tid 140651815413504] [client185.220.101.148:16076] AH01630: client denied by server configuration: /opt/bitnami/drupal/.git[Mon Jan 11 22:48:38.216550 2021] [authz_core:error] [pid 5895:tid 140651731486464] [client185.220.101.148:15044] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Tue Jan 12 00:00:11.000320 2021] [mpm_event:notice] [pid 31324:tid 140652898159488] AH00493: SIGUSR1 received.  Doing graceful restart[Tue Jan 12 00:00:11.079552 2021] [ssl:warn] [pid 31324:tid 140652898159488] AH01916: Init:(it.dimamegroup.com:443) You configured HTTP(80) on the standard HTTPS(443) port![Tue Jan 12 00:00:11.080308 2021] [mpm_event:notice] [pid 31324:tid 140652898159488] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured -- resuming normal operations[Tue Jan 12 00:00:11.080320 2021] [core:notice] [pid 31324:tid 140652898159488] AH00094: Command line: '/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf'[Tue Jan 12 02:13:19.259558 2021] [authz_core:error] [pid 16698:tid 140651974874880] [client 40.86.206.98:62314] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Tue Jan 12 03:33:10.989902 2021] [authz_core:error] [pid 16698:tid 140651798628096] [client 45.155.205.108:41902] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Tue Jan 12 03:33:13.092060 2021] [authz_core:error] [pid 16698:tid 140651773449984] [client 45.155.205.108:41904] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Tue Jan 12 10:09:54.745434 2021] [authz_core:error] [pid 16288:tid 140651924518656] [client 45.155.205.108:51740] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Tue Jan 12 10:09:54.828426 2021] [authz_core:error] [pid 16698:tid 140651832198912] [client 45.155.205.108:60234] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Tue Jan 12 11:10:59.772332 2021] [authz_core:error] [pid 16288:tid 140651874162432] [client 107.189.10.245:42070] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Tue Jan 12 11:10:59.777122 2021] [authz_core:error] [pid 16288:tid 140651882555136] [client 107.189.10.245:42064] AH01630: client denied by server configuration: /opt/bitnami/drupal/.git[Tue Jan 12 17:30:01.939516 2021] [authz_core:error] [pid 16289:tid 140651681130240] [client 45.155.205.108:47404] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Tue Jan 12 17:30:02.094253 2021] [authz_core:error] [pid 16698:tid 140651530061568] [client 45.155.205.108:32826] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Tue Jan 12 17:34:16.338089 2021] [authz_core:error] [pid 16698:tid 140651622381312] [client 51.11.12.36:64573] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Tue Jan 12 20:34:59.169120 2021] [authz_core:error] [pid 16698:tid 140651613988608] [client 52.231.204.102:56845] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Tue Jan 12 20:52:39.474591 2021] [authz_core:error] [pid 16698:tid 140651521668864] [client 185.220.101.198:21914] AH01630: client denied by server configuration: /opt/bitnami/drupal/.git[Tue Jan 12 20:52:39.663452 2021] [authz_core:error] [pid 16288:tid 140651672737536] [client 185.220.101.198:26876] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env[Wed Jan 13 00:00:07.254443 2021] [mpm_event:notice] [pid 31324:tid 140652898159488] AH00493: SIGUSR1 received.  Doing graceful restart[Wed Jan 13 00:00:07.328303 2021] [ssl:warn] [pid 31324:tid 140652898159488] AH01916: Init:(it.dimamegroup.com:443) You configured HTTP(80) on the standard HTTPS(443) port![Wed Jan 13 00:00:07.330297 2021] [mpm_event:notice] [pid 31324:tid 140652898159488] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured -- resuming normal operations[Wed Jan 13 00:00:07.330309 2021] [core:notice] [pid 31324:tid 140652898159488] AH00094: Command line: '/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf'[Wed Jan 13 05:17:58.130744 2021] [authz_core:error] [pid 26458:tid 140651991660288] [client 45.155.205.108:39242] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Wed Jan 13 05:17:58.583788 2021] [authz_core:error] [pid 26848:tid 140651941304064] [client 45.155.205.108:56914] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Wed Jan 13 05:30:27.938812 2021] [proxy_fcgi:error] [pid 26848:tid 140651974874880] (70008)Partial results are valid but processing is incomplete: [client 110.153.67.132:9026] AH01075: Error dispatching request to : (reading input brigade)[Wed Jan 13 07:48:09.065460 2021] [authz_core:error] [pid 26848:tid 140651773449984] [client 51.210.36.31:52656] AH01630: client denied by server configuration: /opt/bitnami/phpmyadmin/scripts[Wed Jan 13 10:30:18.096164 2021] [authz_core:error] [pid 26848:tid 140651706308352] [client 45.155.205.108:43686] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit[Wed Jan 13 10:30:19.590545 2021] [authz_core:error] [pid 26458:tid 140651848984320] [client 45.155.205.108:51322] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit
[Thu Jan 14 15:08:05.283421 2021] [ssl:warn] [pid 4429:tid 140329715383168] AH01916: Init:(it.dimamegroup.com:443) You configured HTTP(80) on the standard HTTPS(443) port![Thu Jan 14 15:08:05.294221 2021] [ssl:warn] [pid 4430:tid 140329715383168] AH01916: Init: (it.dimamegroup.com:443) You configured HTTP(80) on the standard HTTPS(443) port![Thu Jan 14 15:08:05.294418 2021] [core:warn] [pid 4430:tid 140329715383168] AH00098: pid file /opt/bitnami/apache/var/run/httpd.pid overwritten -- Unclean shutdown of previous Apache run?[Thu Jan 14 15:08:05.295050 2021] [mpm_event:notice] [pid 4430:tid 140329715383168] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured -- resuming normal operations[Thu Jan 14 15:08:05.295082 2021] [core:notice] [pid 4430:tid 140329715383168] AH00094: Command line: '/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf'[Thu Jan 14 15:08:16.884696 2021] [mpm_event:notice] [pid 4430:tid 140329715383168] AH00491: caught SIGTERM, shutting down[Thu Jan 14 15:08:17.381070 2021] [ssl:warn] [pid 4788:tid 140528340347776] AH01916: Init: (it.dimamegroup.com:443) You configured HTTP(80) on the standard HTTPS(443) port![Thu Jan 14 15:08:17.390924 2021] [ssl:warn] [pid 4789:tid 140528340347776] AH01916: Init:(it.dimamegroup.com:443) You configured HTTP(80) on the standard HTTPS(443) port![Thu Jan 14 15:08:17.391622 2021] [mpm_event:notice] [pid 4789:tid 140528340347776] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured -- resuming normal operations[Thu Jan 14 15:08:17.391649 2021] [core:notice] [pid 4789:tid 140528340347776] AH00094: Command line: '/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf'[Thu Jan 14 15:12:33.621877 2021] [mpm_event:notice] [pid 4789:tid 140528340347776] AH00491: caught SIGTERM, shutting down[Thu Jan 14 15:12:34.129266 2021] [mpm_event:notice] [pid 5328:tid 139668809288576] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured -- resuming normal operations[Thu Jan 14 15:12:34.129887 2021] [core:notice] [pid 5328:tid 139668809288576] AH00094: Command line: '/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf'[Thu Jan 14 15:15:09.748670 2021] [mpm_event:notice] [pid 5328:tid 139668809288576] AH00491: caught SIGTERM, shutting down

Hi @dantinoesposito,

thanks for using Bitnami. The http2 isn’t working because your certificate is not correctly configured.

Could you change the name of the files of your certificate? a name without ‘.’ something similar to server.crt and server.key. After that change the configuration of apache with the new names of the files and restart apache

sudo /opt/bitnami/ctlscript.sh restart apache

Regards,
Ibone.

Hi @Ibone

the problem, although http2 seems to be ok, somehow it seems to persist in the log file, yet this is what is written in the bitnami-ssl.conf file (no period appears at the end of the two sentences, if I understand correctly)

SSLCertificateFile “/opt/bitnami/apache/conf/websitename.it.crt”
SSLCertificateKeyFile “/opt/bitnami/apache/conf/websitename.it.key”

Thanks

Hi @dantinoesposito,

It seems your certificate is right, could you copy the output of the logs that are you talking about?

Regards,
Ibone.

Hello @Ibone,
you are correct. The certificate works. The problem I am referring to is, I do not understand what it is, whether or not it is related to the http2 fact, why the log file must mark this

[Fri Jan 29 00:00:02.892787 2021] [mpm_event:notice] [pid 5069:tid 140146140597120] AH00493: SIGUSR1 received.  Doing graceful restart
[Fri Jan 29 00:00:02.915158 2021] [mpm_event:notice] [pid 5069:tid 140146140597120] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured -- resuming normal operations
[Fri Jan 29 00:00:02.915172 2021] [core:notice] [pid 5069:tid 140146140597120] AH00094: Command line: '/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf'
[Fri Jan 29 01:02:32.520188 2021] [authz_core:error] [pid 10418:tid 140145177126656] [client 52.14.43.209:50241] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Fri Jan 29 02:53:49.052665 2021] [authz_core:error] [pid 10418:tid 140144715527936] [client 206.189.94.151:59110] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Fri Jan 29 03:22:00.311720 2021] [authz_core:error] [pid 10418:tid 140145093199616] [client 206.189.94.151:45496] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Fri Jan 29 04:33:29.419612 2021] [authz_core:error] [pid 10418:tid 140145051236096] [client 78.47.222.184:53260] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Fri Jan 29 09:54:44.914974 2021] [authz_core:error] [pid 10418:tid 140145267185408] [client 106.52.86.114:50184] AH01630: client denied by server configuration: /opt/bitnami/phpmyadmin/index.php
[Fri Jan 29 10:27:37.687692 2021] [authz_core:error] [pid 10418:tid 140144740706048] [client 172.105.148.25:53120] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Fri Jan 29 12:38:15.402348 2021] [authz_core:error] [pid 9924:tid 140145168733952] [client 45.155.205.108:53484] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit
[Fri Jan 29 12:38:15.484169 2021] [authz_core:error] [pid 10418:tid 140144925345536] [client 45.155.205.108:33162] AH01630: client denied by server configuration: /opt/bitnami/drupal/vendor/phpunit
[Fri Jan 29 14:03:04.287185 2021] [authz_core:error] [pid 10418:tid 140145300756224] [client 92.154.95.236:56394] AH01630: client denied by server configuration: /opt/bitnami/drupal/.git
[Fri Jan 29 15:47:00.118179 2021] [authz_core:error] [pid 10418:tid 140144807847680] [client 18.219.43.204:63683] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env
[Fri Jan 29 17:15:40.670645 2021] [authz_core:error] [pid 10418:tid 140145185519360] [client 92.90.219.15:61874] AH01630: client denied by server configuration: /opt/bitnami/drupal/.env 

Hi @dantinoesposito,

Sorry for the delay here. I reviewed the documentation again and your configuration and found the cause of the problem. The documentation says that you need to add the lines to enable http2 in the /opt/bitnami/apache2/conf/bitnami/bitnami.conf and /opt/bitnami/apache2/conf/bitnami/bitnami-ssl.conf files. Those are the main Apache configuration files. However, as you also have Drupal running in the instance, there are specific conf files for Drupal:

  • /opt/bitnami/apache/conf/vhosts/drupal-vhost.conf
  • /opt/bitnami/apache/conf/vhosts/drupal-https-vhost.conf

You need to add the lines in the VirtualHosts defined there. For example, this is how the drupal-vhosts.conf file should look like

<VirtualHost 127.0.0.1:80 _default_:80>
  ServerAlias *
  Protocols h2 h2c http/1.1
  H2Direct on
  DocumentRoot /opt/bitnami/drupal
  <Directory "/opt/bitnami/drupal">
    Options -Indexes +FollowSymLinks -MultiViews
    AllowOverride None
    Require all granted
  </Directory>
  Include "/opt/bitnami/apache/conf/vhosts/htaccess/drupal-htaccess.conf"
</VirtualHost>

Remember to restart the Apache server

sudo /opt/bitnami/ctlscript.sh restart apache

I tested the changes in this online site (https://tools.keycdn.com/http2-test) and it passed the tests

Note: I’ll notify the documentation team to update the documentation accordingly.

Happy to help!


Was my answer helpful? Click on :heart:

Hi again @dantinoesposito,

I just noticed that our documentation mentions this change

Add the following lines in any Apache virtual host file defined inside the /opt/bitnami/apache2/conf/vhosts/ directory, inside the default VirtualHost directive for each file, so that it looks like this:

So, please update the files in the vhosts folder.

Hello @jota ,

give me a premise: the fact that http2 is working does not mean that it is contemplated to accept equally that the apache log file shows errors, perhaps unrelated to the http2 theme and consequence of some other wrong configuration but as long as we do not know it we cannot even say with certainty that is not a consequence of the http2.

What then, about the configuration that you have reported to me and for which I thank you, I want to say one thing: following those instructions to the letter, the apache file presents a different type of error and that is

(13) Permission denied: AH00072: make_sock: could not bind to address [::]: 80
(13) Permission denied: AH00072: make_sock: could not bind to address 0.0.0.0:80

It was my care, after some time wasted in experiments, to understand that by replacing, from the ones and only the bitnami.conf and bitnami-ssl.conf files (and therefore not also from the files contained in the vhosts folder) the code " <VirtualHost 127.0.0.1:80 default: 80> " with only " <VirtualHost default: 80> " (I repeat: in the files drupal-vhost.conf and drupal-https-vhost.conf and the back versions nothing is touched, ok 127.0.0.1:80): the problem no longer occurs.

Only here, beyond the fact that http2 works the same (with or without 127.0.0.1:80, just follow the Bitnami guide correctly and that is add “Protocols h2 h2c http / 1.1 H2Direct on” to both bitnami.conf file + bitnami-ssl.conf + all files contained in the vhosts folder), the apache log file if it no longer presents the port error, still presents this other type of error which is

AH01630: client denied by server configuration: /opt/bitnami/drupal/.env

How can you go about fixing it and looking at the apache log file without any problems?

Thank you

Hi @dantinoesposito,

It seems there was another process using the port 80. This has nothing to do with the configuration change you were mentioning. Apache was trying to bind the port 80 but it couldn’t do so because it was already in use.

Regarding this error, that’s totally normal. It seems that someone or something (a bot for example) is trying to access your .env file inside the Drupal folder but that information is denied by Apache because it’s configured in the Apache’s conf files. There is some information that can’t be publicly available, for example the configuration files of the app and the app takes care of blocking those requests using the Apache’s configuration. Please take a look at the /opt/bitnami/apache/conf/vhosts/htaccess/drupal-htaccess.conf file.

Happy to help!


Was my answer helpful? Click on :heart:

Hello @jota,

I don’t know how it can be said that the port was used by something else when it is the same one that was used before and after the modification and without killing some other service but simply removing the 127.0.0.1:80 from the bitnami.conf and bitnami-ssl.conf files, however that ends well is good.

Regarding the second error, I understand, it will be as you say, at least it is not an error that means some problem for the server as I thought until recently. Thank you for your support, you can consider this post solved.

Hi @dantinoesposito,

I don’t know if you installed another web server in the instance lately and if that web server is started automatically when the port 80 is free. For example, it can happen that you stop the Bitnami Apache to perform some changes and then you can’t start it because the system’s web server was started automatically. Another option is that Apache is not completely stopped when you try to start it again and that’s why you get that error message. By the way, if your configuration is working properly, I suggest you using it. If you receive the error again, please let us know.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.