HTTP to HTTPS Redirection not working after running bncert-tool

Hi there.
This is a fresh install of PrestaShop on AWS using the Bitnami PrestaShop AMI from the AWS marketplace.
The site was running fine. At least the default template site.
I ran the bncert-tool to install a LetsEncrypt cert. I selected Yes to enable http to https redirection. But now the site won’t load. FireFox is telling me the page isn’t redirecting properly.
If I try to get to the Admin page, I get a login screen. But once I log in the page load fails.

How do I get http to https redirection working?

Support bundle:
eb10c6ad-aa70-d010-831b-1afc055487a3

Which version of the application are you using?:
1.7.6.7-0 on Debian 10

Have you installed any plugin or modified any configuration file?:
Nope

Describe here your question/suggestion/issue (expected and actual results):
As above

Thanks

Hi @ArmitageShanks,

Thank you for using Bitnami. I just accessed your site and it’s working properly. The certificate is valid and the redirection to https is working properly as well

Do you continue running into the same issue when accessing the site? Can you use an incognito window or a different browser when accessing the site?

Thanks

Hi @jota,
I actually spun up a new instance from the MarketPlace Template and moved the elasticIP to point to the new instance. Same domain name and external IP. I did all the same things, but this time it worked fine. I suspect that I may have screwed up one of the .conf files when I was trying to troubleshoot another problem I was having rewriting www to non-www after I originally installed the cert. Which I fixed in Route53 anyway.
In any case, all good now. Thanks for checking in.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.