Http error 500 wordpress google cloud

Keywords: WordPress - Google Cloud Platform - How to - Domain Name (DNS)
Description:
fc61111c-e6da-90e0-60de-38e31c5c5468

I have had this problem for several days on my website www.digitaljpcompany.com and well, although everything was normal and happiness, this error suddenly appeared but I remember that it was when I was modifying this:
define (‘WP_SITEURL’, ‘http://www.digitaljpcompany.com/’);
define (‘WP_HOME’, ‘http://www.digitaljpcompany.com/’);

Well after a while the problem happened but I’m not sure if that has something to do with it but I do remember that it was the last thing I did.
sorry if my english is bad but i only speak spanish and i am using google translator

Hi @martin_yjp,

Thanks for using Bitnami. According to the Apache logs, there is a syntax error in the wp-config.php file

[Sat Apr 24 17:02:39.738465 2021] [proxy_fcgi:error] [pid 4270:tid 140615954134784] [client 184.75.209.26:9170] AH01071: Got error 'PHP message: PHP Parse error:  syntax error, unexpected 'define' (T_STRING) in /opt/bitnami/apps/wordpress/htdocs/wp-config.php on line 99'

That line is shown below

define ('WP_SITEURL', 'http://www.digitaljpcompany.com/');<200b>
define ('WP_HOME', 'http://www.digitaljpcompany.com/');

As you see, there is an invalid <200b> string there. Can you remove it and restart the services to see if it solves the errors?

image

in my case I can’t see the <200> and therefore I can’t delete it, how can I know where it is? but I will show you this image so you can see what I see today that I enter to try to eliminate it I did not find it.Captura define wp

Hi @martin_yjp,

Thanks for the info. Can you tell us which editor are you using? This is how I’m seeing the file content when using vim.

Can you try with another editor?

I am entering from the SSH of the google cloud platform because for now it is the only one that I will use, but if you suggest another way to eliminate the <200> element, I will do it immediately please.

image

I have deleted all those lines that had that problem, I wrote them again but now the error is this. What happened ?

Hi @martin_yjp,

Thanks for the info. I think I know what is your issue now. You set the WP_SITEURL and WP_HOME params to a different value than Apache. To be more specific, Apache is trying to serve your website at https://www.digitaljpcompany.com/, but WordPress is doing it at https://digitaljpcompany.com/, and it is producing the redirection loop. Can you configure the wp-config.php file with https://www.digitaljpcompany.com/ and restart the services?

HTTP/1.1 301 Moved Permanently
Date: Tue, 27 Apr 2021 19:26:26 GMT
Server: Apache
X-Powered-By: PHP/7.4.16
X-Redirect-By: WordPress
X-Frame-Options: SAMEORIGIN
Location: https://digitaljpcompany.com/
Content-Type: text/html; charset=UTF-8

HTTP/1.1 301 Moved Permanently
Date: Tue, 27 Apr 2021 19:26:26 GMT
Server: Apache
X-Frame-Options: SAMEORIGIN
Location: https://www.digitaljpcompany.com/
Content-Type: text/html; charset=iso-8859-1

This page is online now, I have been able to solve that and I am very grateful to that issue, however now that I want to enter the wordpress editing platform through the link:
https://digitaljpcompany.com/wp-config.php

I can not because the screen is completely blank on the computer, what can I in this case to enter and configure my website?

I just realized that it also does not allow me to enter:

www.digitaljpcompany.com/wp-login.php

www.digitaljpcompany.com/wp-admin.php

Although in the first one of login.php it appears to me to put my access data but when I enter them it comes out as a page not found and in the second one of admin.php it tells me that the page is not


Hi @martin_yjp,

Can you run the bnsupport tool again and send us the new code? We would like to check the updated logs and configuration.

Regards,
Gonzalo

This ? :

fc61111c-e6da-90e0-60de-38e31c5c5468

This is new: 51588ed3-c97a-e653-c5cd-fe484c5d3a5f

Hi @martin_yjp,

Thanks for the new code. I checked your wp-config.php file again and it looks like you are having a different syntax error now. Can you check it? This is what I see in the lines were the WP_SITEURL and WP_HOME variables should be defined

As you see, they aren’t properly defined. Can you tell us which editor are you using? Can you use a different one, for example nano? We have an introduction guide on how to use it

https://docs.bitnami.com/google/faq/administration/edit-privileged-files/

If you keep having issues, please run the bnsupport tool again so we can check the updated config.

fd311c38-4f18-9700-310b-2a8ce2fe2e83

I have had the same problem at the beginning of that post. boy is it hard.

Hi @martin_yjp,

Unfortunately, I still see those weird lines. Can you tell us which editor are you using? Alternatively, can you download the file to your local machine, edit it and the upload it again?

https://docs.bitnami.com/google/faq/administration/upload-files/

borre todo y lo hice nuevamente y funciono ahora. Thanks


I deleted everything and did it again, seems to work now. Thanks

I am glad to see you were able to solve your issue! We are marking this thread as resolved and proceeding to close it.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: