Http://127.0.0.1:8888/phpmyadmin/ gives 500 internal error

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Other
Description:
All was working fine until I suddenly discovered that accessing my remote Lightsail MySQL db via the URL http://127.0.0.1:8888/phpmyadmin/ gives me a 500 internal error.

I then ssh ed into my instance, ran apt-get update, installed Lynx and then tried to open 127.0.0.1/phpmyadmin .

There too, I got the same 500 Internal error !

Can anyone please point me towards something that might have gone wrong, due to which phpmyadmin has suddenly become inaccessible?

Thanks in advance!

Support tool id: 0ceb986a-a709-38fb-8980-6c89212ff126

Hi @rajiv

Thanks for using Bitnami LAMP!

Our support tool has identified the following issues, could you please take a look at them?

? Apache: Found possible issues
? resources: Found possible issues
✓ mysql: No issues found
✓ php: No issues found

Found recent error messages in the Apache error log.

[Mon May 03 17:30:30.676477 2021] [proxy_fcgi:error] [pid 1160:tid 140718118872832] [client 127.0.0.1:52688] AH01071: Got error 'PHP message: PHP Parse error:  syntax error, unexpected '>' in /opt/bitnami/phpmyadmin/tmp/twig/22/226c4486b6510232787cb63effe7563595f34465cf9ec584fe83e992e065b271.php on line 98PHP message: PHP Fatal error:  Exception thrown without a stack frame in Unknown on line 0'

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

Your instance has little available RAM memory. You could try to increase your instance’s memory. Please check your cloud provider’s documentation for more information.

You can also enable swap memory to improve performance.


The first one seems to be the one causing the 500 Internal Error to me. Have you modified this file? Have you performed any other modifications to the PHPMyAdmin files?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hello @jcarmona!

Thanks for your response. I will do the needful to increase the RAM of the instance.

However, I am surprised about this error because I have not modified any file!

Any idea how that could have happened?

[SOLVED]: Thanks to the info about the file in question provided by @jcarmona, I opened the file in vim and saw the unexpected character ‘>’ at line 98.

I then removed the character and saved the file. Then tried to access 127.0.0.1/phpmyadmin via Lynx from the terminal. Got the same 500 Internal Error.

So, I renamed in the the fil in the temp folder.

This worked!

This is what i did :

sudo mv /opt/bitnami/phpmyadmin/tmp/twig/22/226c4486b6510232787cb63effe7563595f34465cf9ec584fe83e992e065b271.php /opt/bitnami/phpmyadmin/tmp/twig/22/226c4486b6510232787cb63effe7563595f34465cf9ec584fe83e992e065b271_copy.php

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

1 Like