How to stop mariaDB from EC2 running on Debian?

Keywords: OpenCart - AWS - How to - Other
Description:
How to I stop completely mariadb from EC2. Currently, I’m using RDS, so it’s not needed for me to run MariaDB inside the EC2. So I want to disabled it permanently.

I tried to:

  1. remove /etc/monit/conf.d/mariadb.conf

and it seems that it’s not running by running “sudo gonit status”

However, if I check with “htop”, i still see many process/instances of mariadb.

How can I disabled mariadb completely?

Thank you

Hi @harry503,

We have a Support Tool that will gather relevant information for us to analyze your configuration, running processes and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Hi, here is the code fb15a538-1709-5e00-f186-a486d82d32a3.

Hi @harry503,

thanks for the info. To stop and disable MariaDB in your solution, please run these commands

sudo /opt/bitnami/ctlscript.sh stop mariadb
sudo /opt/bitnami/ctlscript.sh status
sudo mv /etc/monit/conf.d/mariadb.conf /etc/monit/conf.d/mariadb.conf.disabled
sudo gonit reload
sudo /opt/bitnami/ctlscript.sh status

You should see that MariaDB is stopped when running the first status command and it shouldn’t be listed in the output of the second one.

Happy to help!


Was my answer helpful? Click on :heart:

It seems that it’s still running. When I try to run
sudo /opt/bitnami/ctlscript.sh stop mariadb and sudo /opt/bitnami/ctlscript.sh stop mysql, the result is showing that it’s not running.

  • Failed to stop mariadb: Cannot find check with id mariadb
    and
  • Failed to stop mysql: Cannot find check with id mysql

But it seems that either mariadb /mysql is running from htop

Hi @harry503,

It seems you disabled the MariaDB service before stopping it. Let’s try to recover the .conf file and stop the database

sudo mv /etc/monit/conf.d/mariadb.conf.disabled /etc/monit/conf.d/mariadb.conf
sudo gonit reload
sudo /opt/bitnami/ctlscript.sh stop mariadb
sudo /opt/bitnami/ctlscript.sh status

Is the database stopped now? Please share a screenshot with the output of the commands.

If the database is stopped, run these other commands now:

sudo mv /etc/monit/conf.d/mariadb.conf /etc/monit/conf.d/mariadb.conf.disabled
sudo gonit reload
sudo /opt/bitnami/ctlscript.sh status
1 Like

It’s solved. Thank you :bulb:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.