How to migrate database from win redmine 4.1.0-8 to win redmine 4.0

Keywords: Redmine - Windows - How to - Other
Description:
I took a backup from bitnami redmine 4.1.0-8 as backup.sql. I installed a fresh bitnami redmine 4.0 to be able to use some plugins which are available for 4.1. But when I try to upload the database upload fails.

I searched the forums and I found some hints.
https://dev.mysql.com/doc/refman/5.7/en/downgrading-to-previous-series.html
Using workbench (https://dev.mysql.com/downloads/windows/installer/5.7.html)
I connect to the database and apply the commands.
During the upload warned me about the 767 bytes data and I found I ave to cahnge the definitions for the variables from 255 to a value below 190 (when we multiply 4 not to exceed 767). I found and replaced all 255 to 190.
Even it seems to be uploaded to 4.0 nothing works and I couldn’t see anything in Redmine 4.0.
Database names are same. I changed the name of the databases over ppmyadmin page.
What should I do?

Hi @kamilafacan,

Can you elaborate a bit what are you trying to achieve and how are you trying to migrate the database? Are you using the command line client or phpMyAdmin/Workbench?

I took a backup from bitnami redmine 4.1.0-8 as backup.sql. I installed a fresh bitnami redmine 4.0 to be able to use some plugins which are available for 4.1. But when I try to upload the database upload fails.

I understand you are migrating a database for Redmine 4.1.0 to Redmine 4.0.x. You also mention that you plan to use some plugins for Redmine 4.1.x on your Redmine 4.0.x website. Unfortunately, I’m not sure if it is possible to achieve what you are trying to do. I understand some plugins or features available for Redmine 4.0.x may work on newer versions, but I’m not that confident for the other way around. Also note these concerns must be due to my lack of knowledge regarding Redmine.

We highly recommend you to ask in the official Redmine forums if this process is supported, as the database changes for the latest versions must not be backward compatibles. And the same for the plugins.

https://www.redmine.org/projects/redmine/boards

For the database it is correct I try to migrate. I am taking a backup using the command

mysqldump -A -u root -p > backup.sql

When I directly upload the database Bitnami Redmine 4.0.2, it fails.

I opened this via phpMyAdmin page and renamed it again failed.
Then used Workbench and changed acc to the mysql recommandations.

https://dev.mysql.com/doc/refman/5.7/en/downgrading-to-previous-series.html

The reason I want to downgrade is there aree some plugins which are not available for Redmine 4.1. version. They are working with Redmine 4.0.

I will ask Redmine Forum also, thanks for your response.

I found from the changelog. Redmine 4.1. and 4.0.5 has the same mysql version (5.7)

Version 4.1.0-8 2020-02-06
_ Updated MySQL to 5.7.29_*

Version 4.0.5-6 2019-11-29
_ Updated MySQL to 5.7.28_*

As I searched migrating between the 5.7.x or 5.7.y in terms of version does not cause any problem.
If I could run the plugins within this version (4.0.5-6) this could

Where can I find this version?

Hi gentlemen
I am confused sorry. I fact I am using Bitnami Redmine Plus Agile 4.1.0-8. I need a Plugin for reporting the status of the pojects via graphs. I found the pivottable plugin. It is working with Redmine 4.0.2 (max). For that reason I decided to downgrade to 4.0.2.
As I told in the previous post, I recognized that 4.0.5-6 also has mysql 5.7. Somehow I found in the net and then I tried this plugin in it. At first it seemed as working but when exit and try to enter, redmine collapsed.

I start to search again and saw that also Redmine 4.0.2 also has the 5.7 for mysql as it is announced in the Changelog.

image

But after installing I tried to upload my data which was baked up from Redmine 4.1.0-8, but I got some errors on screen. I opened the phpmyAdmin and Workbench to see the database I saw that the database is not 5.7.

image

Is there any version of Redmine 4.0.2 which has mysql 5.7. ? Or Do we have the opportunity to change the mysql ver and how?

Thanks in advance.

Hi @kamilafacan,

Can you tell us which link did you use to download the required installer? Are you sure the MySQL server you are running in the port 3306 is the one Redmine is using?

I downloaded the Bitnami Redmine 4.0.5-6 Windows installer and I see in the command line that MySQL is version 5.7.28, the same one mentioned in the changelog.

image

Note the changelog you are posting is for Redmine 4.0.2-2. Can you ensure you are connecting to the correct MySQL server?

I downloaded the Redmine 4.0.5-6 installer from the next link

https://downloads.bitnami.com/files/stacks/redmine/4.0.5-6/bitnami-redmine-4.0.5-6-windows-x64-installer.exe

Hi @gongomgra
I think it is a litle mixed up. For the version 4.0.5 it OK version is 5.7.
In the second post I tried to explain.
With 4.0.5 version I tried the pivottable plugin, it worked at the beginning then failed. For the data there is no problem, I managed to upload te backup.sql taken from 4.1.0-8.

When I detailly check the verion for the plugin I saw the max 4.0.2.
For this version, in the changelog I saw mysql ver 5.7. and I was very happy, but when I install and try to upload backup.sql it failed. Then I checked the version from phpmyAdmin page.

Now I didn’t remember the download link for 4.0.2. If you could provide and if it is made with mysql ver 5.7… I may try and hopefully solve my problem.

I hope I can explain.

Hi @davidg

I have seen your post.

Could you please share the link for 4.0.2-3 which includes the mysql 5.7.

Thanks a lot

Hi @kamilafacan,

Please find below the download link for the requested version.

https://downloads.bitnami.com/files/stacks/redmine/4.0.2-3/bitnami-redmine-4.0.2-3-windows-x64-installer.exe

I tested it on my Windows computer and I verified it uses MySQL 5.7

image

Note it is possible that the downgrade process for Redmine requires additional steps. You will need to ask in the Redmine forums for help on this.

Hi @gongomgra

You are so kind. I will try at first instance and also inform you and the other collaques from here. Because as I investigate this version is a transition for the Mysql 5.6. and 5.7.

Best regards

This subject is solved for me. I used the explanatioons also mentioned in

There are some problems but they are caused by plugin and I am going on that way.

Thanks, regards @gongomgra

Hi @kamilafacan,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.