How to install Testlink on Mac OS X

I installed the .dmg file installer of Testlink on my mac os X (localhost), then I read the manual guide to connect this software to mysql on localhost, but the manual guide seems to be fine for windows platform only I guess.

I found it’s written like

From your web browser access http:///testlink_web_dir/andyouwill be redirected to installation script: http:///testlink_web_dir/install/index.php.

But I cannot open it from my localhost site.
If I opened http://127.0.0.1:8080/testlink/login.php then I can see positive result of testlink login page, but when I opened http://127.0.0.1:8080/testlink_web_dir/install/index.php or 127.0.0.1:8080/testlink/install/index.php or 127.0.0.1:8080/install/index.php, I see result

Not Found
The requested URL /testlink_web_dir/install/index.php was not found on this server.

Maybe I took it way too literally about testlink_web_dir, I do not know the testlink actual directory.
Please help me, what should I do to connect testlink that I just installed to mysql (I already created a database named testlink from mysql server)…

Is it a problem that when I was installing the testlink.dmg file, I chose port 3007 when it asked me about my mysql port (which my mysql port running on 3006, but if I entered 3006 it won’t pass and got error like “please select another port, cannot bind it to the port” something like that. By the way, I didn’t install any new apache or php or mysql on my mac because I saw that they’re built in on os X.

Much appreciate for help… I am a newbie on installing app on mac.
Thank u very much…

Hi @mercia01,

If you have installed our stack, you have not to follow the steps to install Testlink, because our stack gives you Testlink ready to use (connections with db, users created…).

Hope it helps.

Best regards,
Alejandro.

Thank you! Now I find it much easier…

Thanks for letting us know. I am glad it worked for you. We marked this ticket as ‘solved’. Please reopen this case if you require further assistance.

Best regards,
Alejandro.

Hi, can you help me. I have installed testlink on my mac machine but it has never asked me to enter username and password when I copied file to application folder. So I have no admin login there and can not access it as admin. Guest login is not any use.

Hello @manish.bhati180,

I guess you have installed an OS X VM.
https://docs.bitnami.com/installer/faq/osx-vm-faq/

In this case, default credentials are:

user
bitnami

I hope it helps

Hi @davidg,

I have installed OS X VM in my mac machine and i am able to login with the above credentials. My Testlink site launches with a default IP http://192.168.64.3/.

Can you please let me know how to host the Testlink from my mac, so that my team can access from their machine in LAN?

Thanks
Dinesh

Hi @dinesh-sd,

As you can see in this previous post, in order to allow access to your installation, you need to set the necessary rules on your Mac OS X firewall (by default it is off, so all incoming connections are allowed). Find more info here

You should forward your VM 80 and 443 ports to your local machine’s ports. For that, use the Network tab in your OS X VM. E.g. the screenshot below forwards the port 80 of VM with port 80 in the local machine.

That way, PCs in the same LAN could access using your local IP (ipconfig getifaddr en0)

I hope it helps

Hi, how is it possible to change it?

Hello @heidisophiakramer,

First, you need to access General tab and click on Start. After that, you should be able to edit it.

Regards

Hi, I have installed bitnami stack on Mac. I can access test link login page on localhost:8080 but when I try to use default credentials “user” and “bitnami” I get an error “Try again! Wrong login name or password!”.

Hello @sandeep.kaur,

Since this is another topic, could you please open another case with this information? The idea is to avoid mixing topics in the forum.

Regards

Hi! I recently download testlink for mac and i received this message after clicking “Start”, any tips? I just download the file and installed.

Hi @gustavo.beron,

Thanks for using Bitnami. This is an old thread we will close to avoid mixing different topics. Could you check other threads in this forum for this same error? Please find below a couple of links that may be relevant

Please open a new thread in the forum if you continue having issues after checking the threads above.