How to get HTTPS working ( :80 & redirect loop issues resolved.) (Ghost/GCP)

Keywords: Ghost - Google Cloud Platform - How to - Secure Connections (SSL/HTTPS)
Description:
Here’s how to fix the HTTPS problems ( :80 and redirect loop)

I spent some time troubleshooting a blocker that’s stopped me from using the Bitnami Ghost container in production.

There are two issues after setting up your SSL certificate. You’ll notice your nav links have :80 appended to the end, and of course lack the S in https.

First part - Fix Ghost URL

Stop Ghost

sudo /opt/bitnami/ctlscript.sh stop
sudo vi /opt/bitnami/apps/ghost/htdocs/config.production.json

Edit the URL part to include the S after http. Remove the :80

Second part - Enable Apache’s protocol proxy pass.

sudo vi /opt/bitnami/apps/ghost/conf/httpd-app.conf

Add this to the top of the file:

RequestHeader set X-Forwarded-Proto "https"

Restart Ghost.

sudo /opt/bitnami/ctlscript.sh start

Voila. /kc

7 Likes

Hi @kevc1973,

Thank you for sharing your knowledge with the Community for everyone’s benefit. :slight_smile:

Regards,

Michiel

1 Like

Whenever I would enable https in the config.production.json file it would dump me out on 127.0.0.1:2368 and say it couldn’t establish a connection. This solved that issue completely.

I’m only replying because you put “httpd-app.com”, should be conf:

sudo vi /opt/bitnami/apps/ghost/conf/httpd-app.conf

1 Like

Thanks, I fixed the post :slight_smile:

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.