How to disable certificate requirement for local VM-based bitnami LAMP stack?

Keywords: LAMP/MAMP/WAMP - Virtual Machines - Technical issue - Connectivity (SSH/FTP)

bnsupport ID: 5923e96f-c4a8-17f4-c65d-847d3039da39

bndiagnostic output:

? Resources: Found possible issues
? Connectivity: Found possible issues
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
Hello!
I download and convert into VirtualBox, running on my PC fresh
bitnami-lampstack-8.0.8-0-linux-debian-10-x86_64-nami.ova
Then I enable SSH access as discribes in this article. So, when I trying to connect via SSH, I got the No supported authentication methods available (server sent: publickey) error.
I don’t plan to run this app in the any Cloud Platform also I don’t going to open public access to the SSH port thus, I need only basic access to this VM.

Can somebody tell me how to enable basic SSH access into VM?

Other Bitnami VMs, that i used before, did not ask this stuff, and article has no words about this as well as other founded community articles :frowning:

Hi @Rednaxel,

It seems you have some SSH keys already loaded in the terminal and it’s trying to use those ones when accessing the console. Can you try to run this command in the host terminal to access the VM?

ssh -o PasswordAuthentication=yes -o PreferredAuthentications=keyboard-interactive,password -o PubkeyAuthentication=no bitnami@IP_OF_THE_VM

Happy to help!


Was my answer helpful? Click on :heart:

Command returns the same result:
Warning: Permanently added ‘192.168.137.110’ (ECDSA) to the list of known hosts.
bitnami@192.168.137.110: Permission denied (publickey).

However, I have been used the same terminal client with the same settings to connect to the other SSH servers, including 2 VM Bitnami WordPress stack, that was installed 1-2 years ago and everything is OK.

Only fresh images - I trying to download some other variants – generate the issue.

IMHO developers added some features to that images :frowning:

Just try to use your command to access fresh installed CentOS server whith OpenSSH and it succesfully connects

Hello @Rednaxel,

It seems newer instances may have ssh PasswordAuthentication disabled by default. Could you check if that is the issue? You can use the following guide as a reference:

https://docs.bitnami.com/virtual-machine/faq/get-started/enable-ssh-password/

Regards,
Francisco de Paz

1 Like

It works, thank you so much!
So easy to fix – just delete one # – but so hard to found!
Espeshilly especially a big hello to wise developer, that put this rakes here and didn’t think to edit the documentation :wink:

Hello @Rednaxel,

I’m glad the issue got solved! It seems the ssh configuration was indeed modified, though it wasn’t a conscious decision on our side so I will ping the development team to check on it.

I also agree with you in that we could add links to the password/key-based configuration guides in the Enable The SSH Server section of the guide you linked, I have created an internal ticket for the documentation team to improve the guide.

Thanks,
Francisco de Paz

Good idea, many thans from other rake-walkers!
So, let’s continue our way through the other rakes.
:slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.