How to create a directory

Keywords: WordPress Multisite - AWS - How to - Connectivity (SSH/FTP)

Description:
Hello,

I’m trying to create a new directory under my IP address path http://11.111.111.11/newdirectory using FileZilla Pro but I get an error
“Error: mkdir /newdirectory: permission denied” .

Is it possible to complete this task of creating a new directory in another way?

Thank you

note: I’m using a .ppk key to connect to my site and I run the FileZilla app as an admin.

Hi @klitos20,

It seems you are creating the directory in the root path of the instance, not inside the WordPress’ folder. Please move to /opt/bitnami/apps/wordpress/htdocs or /opt/bitnami/wordpress (depending on when you launched the instance) and create the new directory there.

You can also run this command in the command line

mkdir /opt/bitnami/wordpress/newdirectory || mkdir /opt/bitnami/apps/wordpress/htdocs/newdirectory

If you continue running into issues when creating that folder, please create a new ticket in the forum selecting “Technical issue” during its creation so the Bitnami team receives more information regarding the issue.

Thanks

Hello @jota,

Thanks for the reply. I managed to create the directory successfully.

Now I’m trying to install my SSL certificate inside the apache webserver and I need to upload the two certificate files in the directory /etc/ssl/ and one file in the /etc/ssl/private/ directory. The first directory is accessible but I don’t seem to have write permissions and for the latter directory I don’t have any permission to access it.

These are the steps which I’m trying to complete: https://help.zerossl.com/hc/en-us/articles/360058295854

Could you please assist me to complete the steps?

Hi @klitos20,

The guide you are following doesn’t use the Bitnami installation path. If you have a valid SSL certificate, you can follow this guide to replace the dummy one we create.

https://docs.bitnami.com/aws/apps/wordpress-multisite/administration/enable-https-ssl-apache/

Once you replace the server.crt and server.key files, please restart Apache

sudo /opt/bitnami/ctlscript.sh restart apache

Happy to help!


Was my answer helpful? Click on :heart:

Hello @jota,

Thank your for the instructions. I have followed them and uploaded the SSL certificate I issued from Zero SSL (I used this because it is free) and it seems that my IP address has an SSL now as you can check here

SSL Hopper

https://www.sslshopper.com/ssl-checker.html#hostname=18.135.235.12

Is there a way to link it? I believe that without the SSL link between the IP address and domain name, my Cloudfront distribution won’t be able to pull content from my origin using HTTPs. Currently I have it set to HTTP but my aim is to change this to HTTPs if possible.

Just for reference, I’m using AWS Lightsail.

Thank you, I appreciate your help!

Hi @klitos20,

In order to use a domain name in your site, you need to get a domain name first and then configure that domain name with the IP address of you instance. Once you’ve done that, you will also need to configure the SSL certificate to validate your new domain (not the IP address or the AWS domain).

Happy to help!


Was my answer helpful? Click on :heart:

Hello @jota,

I managed to create the SSL certificate using certbot in the end and somehow it worked out.

Thank you for the assistance!