How to configure https for secure connection when using in Google Cloud Platform

I have just created a redmine installation on a compute engine in google cloud platform.
So I have my redmine installation on the cloud. google has provided me with an external IP address

When I go to this IP address, I get

your connection is not secure.

How do I configure the compute engine instance or redmine to make this IP address secure.

HI @kray42

Redmine is configured to be offered via http, so Redmine might not be the problem, could you send us a screenshot of the error you are getting?
Anyway, if you want to configure Redmine to use SSL connection you could follow this guide : https://wiki.bitnami.com/Applications/BitNami_Redmine#How_to_enable_SSL.3f

Regards,
Juan

image

This is the message i get from firefox when I go to the URL.
The URL (or IP address) is a compute engine instance in Google Cloud Platform.
I am running bitnami-redmine on a cloud.

Hi @kray42

Could you provide us more information about your issue? We need information about the content of the next files:

  - /opt/bitnami/apps/redmine/conf/httpd-app.conf
  - /opt/bitnami/apps/redmine/conf/httpd-prefix.conf
  - /opt/bitnami/apps/redmine/conf/httpd-vhosts.conf

Regards,

Juan

I am a newbie when it comes to cloud and the whole aspect of deploying bitnami-redmine on the compute-engine instance of google cloud platform.

So I do not know how to login to the compute-engine instance. I guess I will have to use putty or some other terminal to connect and login to the server where bitnami-redmine is installed.
I do not have any user-id or the root password also.

Can you tell me how to login to the system and then I will be able to give you the various .conf files.

Hi @kray42

Here you have a guide that will help you to do it. Please have a look at it and do not hesitate to ask for help if you have any problem.

https://wiki.bitnami.com/Google_Cloud_Platform/Servers#Connecting_through_a_terminal

Regards,
Juan

Thanks I have been able to ssh into the machine using the browser.
I can see all the files in the various directories.
I saw the files in /opt/bitnami/apps/redmine/conf

I will send you the files later as soon as i have figured out how to ftp to the compute-engine on google cloud.

Hi
I cant attach the .conf files, since your web app only allows images.
So I have typed them in the terminal and attached a screen shot.

Hi @kray42

You don’t have any problem on your configuration.

Bitnami images come with SSL support already pre-configured and with a dummy certificate in place. Although this dummy certificate is fine for testing and development purposes, you will usually want to use a valid SSL certificate for production.

This dummy certificate is a self-signed certificate and that is the reason why your browser tells you that the connection is not secure when you access it through Https protocol. However, the connection is secure so you don’t have to worry about it. You can add it as an exception on your browser.

If you want this message to disappear you need a valid SSL certificate for production and then configure your server properly, you can find information about how to do it at:
https://wiki.bitnami.com/Components/Apache#How_to_enable_HTTPS_support_with_SSL_certificates

Best regards,

Juan

I know this is an old thread, but I am new to Bitnami. We purchased the Bitnami Wordpress (for one site) through the Google Cloud Platform and have successfully migrated our current wordpress site over. I found this statement at this Bitnami document that says, "“Bitnami stacks come with HTTPS enabled by default. To make this happen,…” Does this mean when we point our domain to the GCP IP address with our A Record that we will have https (SSL) included with the Bitnami package or will be charged more for the SSL certificate? At this page is mentions setting up a Let’s Encrypt certificate. If this Let’s Encrypt certificate works for us, is there an additional charge or is it included in the package?

Hi @brady,

A Let’s Encrypt certificate is free of charge. HTTPS enabled by default means that the Stack is prepared by us to use HTTPS. The certificate itself should be issued by you and this can be either a commercial one or a free one like Let’s Encrypt.

Best regards,

Michiel D’Hont


Please, click on :heart: if you think my answer was helpful

This Link shared by you takes me to main bitnami page, which lists all the stacks which bitnami offers to be deployed. How can we find the topic ‘How to enable HTTPS support with SSL certificates’ (I also tried searching the same exact words in bitnami support forums).

You can find the guide here:

https://docs.bitnami.com/general/how-to/generate-install-lets-encrypt-ssl/


Please, click on :heart: if you think my answer was helpful

1 Like

Thank you for your response.
But it happens indeed with many many links (found on youtube and other external blogs etc) which should lead to some support articles on Bitnami, but instead, which just lead to main bitnami stacks page.

Why that happens? Is there a way to find that desired help article when those links don’t lead to correct places? I wish that I could report all those links whenever and wherever that happens.

Unfortunately not all the links are working. We will investigate it. As a workaround you could find guides is using the search bar of the documentation.

1 Like

The ‘Tick Mark’ icon, with which we marked an answer as ‘chosen solution’ isn’t appearing on this thread, below your reply.
Am I missing something here?

Weird. I don’t know why it doesn’t show up. I’ve marked it as a solution for you.

1 Like

I successfully implemented SSL/https for my bitnami discourse website hosted on GCP following your advice/link given here above.

But, it still shows a yellow exclamation mark over green lock icon in the url bar, indicating ‘Parts of the page are not secure’. Even though I’ve not changed anything at all in the bitnami implementation till this moment.
My website in question is: https://bathindahelper.xyz/ (sometimes I close this instance when it is night time in India).

Also, when I type bathindahelper.xyz, my FF doesn’t auto redirects to https version. While with other websites, it does this ok.

I checked the website on Chrome, I didn’t get any warning it was not secure. Regarding forcing HTTPS, the following tutorial shows how to do that:

https://docs.bitnami.com/general/infrastructure/lamp/administration/force-https-apache/


Please, click on :heart: if you think my answer was helpful

1 Like