How to configure email service with Microsoft exchange server

I am trying to configure the email service for my Review board. I think I should configure it in the web page of {Your_review_board_address}/admin/settings/email/. However, when I test it by mark the option “Send a test e-mail after saving”, it always fail.

From my Outlook Web App page, I found the Mail Server should be smtp.office365.com, and the port number should be 587 for TLS authentication. However, what should I set for the username and password? Should it be my email address or my company account name? Any suggestion is welcome!

Thank you in advance!

System: Red Hat Linux

Hello @7zijian

You can check all the information in the ReviewBoard Docs section below:
https://www.reviewboard.org/docs/manual/dev/admin/configuration/email-settings/

As you will find there you need to indicate the credentials of the mail account you want to use to send the mails.

I also recommend you to take a look to the TroubleShooting Guide below:
https://docs.bitnami.com/installer/how-to/troubleshoot-smtp-issues/

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

1 Like

Thank you for you reply!

I have read the two links, may I ask where is the place that I can configure the Email server by SSH? Because it always does not work when I confiugre it via the administration UI page.

Hi @7zijian

You could try by editing the configuration file /opt/bitnami/apps/reviewboard/htdocs/venv/lib/python2.7/site-packages/django/conf/global_settings.py where you’d find the mail configuration parameters. Do not forget to resart the services after the changes.

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

1 Like

Hi,

Thank you for your reply!

Actually, I fixed the problom in the administration UI page. Even though the testting email function seems still does not work, other email functions are working well such as notification of creating a review request or closing a review requrest.

However, after I saw your post I went into the global_settings.py, I found that the settings in the file seems did not synchronise to the settings I made in the administration UI page. The server host setting is still

SERVER_EMAIL = 'root@localhost'

ps: I have restarted the servers, but the settings in the file don’t change.

Hi @7zijian,

As per your information, it seems the email notifications are working fine but the testing email. I just tested a fresh deployment of our latest version of the Bitnami ReviewBoard stack and configured the SMTP settings using the admin panel. Before sending the test email, we also modified the default user’s email under the “My account” section. The test mail was received properly in our inbox.

We tested this with a GMAIL account. I suggest you ask in the official forums of the application to get more information about how to debug this issue.

https://groups.google.com/forum/#!forum/reviewboard

Do not hesitate to write us back if you have any other question or suggestion.

Regards,
Jota

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.