How to change http.header.secure.x.frame.options property in in liferay 7.3.2-1?

Keywords: Liferay - Windows - Technical issue - Other
Description:
How can i change http.header.secure.x.frame.options system property in my Bitnami Liferay ?
I have open portal-ext.properties but it does not contain any of above property , plz help

Hi @alinizamani72

Thanks for using Bitnami Liferay!

Can you tell us a little bit more about the background of your changes? If you are trying to use iframes, we have a thread that covers the same topic:

Could you please check it out and confirm if it works for you :slightly_smiling_face:?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi
Let me elaborate my issue,
My objective is to call “other website” page in iframe of my liferay portal .
We can take an example of yahoo page
Plz have alook , on my page , I have created and embedded page , and place yahoo URL
Have a look to this

I just add an iframe widget from widget tool bar.
When I open this page , it appears like this , instead of required yahoo page


Check the page, it redirect to home page !!!, it should open yahoo.com as required.
I found base URL is wrong it should be www.yahoo.com , instead of http://mybaseurl/group/pphi-sindh/www.yaoo.com
Plz help
can we communicate on skype ? XXXXXX is my id?

Hi @alinizamani72

My objective is to call “other website” page in iframe of my liferay portal .

In that case, I think you need to specify the complete URL (including protocol) when creating the frame page.
E.g.: instead of www.bitnami.com you will need to write https://www.bitnami.com

Could you please try that?

can we communicate on skype ? XXXXXXX is my id?

I am sorry but we limit our free support to this forum and don’t provide that kind of assistance. We will be more than happy to guide you here :slightly_smiling_face:

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Dear,

lets narrow down it, my liferay portal is none secure , when i request to some secure HTTPS URL , it rejects my request.!!!
How can we bypass this issue ?

I study and find the do able way to update System.properties file and update http.header.secure.x.frame.options=false
but unable to find this property in Bitnami liferay version…

If i am correct , can you plz guide me where from to change that property
Regards
Ali

Hi @alinizamani72

According to this article in the official Liferay site, https://help.liferay.com/hc/en-us/articles/360018538452-X-FRAME-Options-Reference-Guide

The system.properties file can be found inside portal-impl.jar, which is found in the path:

$ sudo vim /opt/bitnami/apache-tomcat/webapps/ROOT/WEB-INF/lib/portal-impl.jar

Could you please try to change that and report back?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: