How do I enable ssl on my local installation of VM OS X Multisite?

Keywords: WordPress Multisite - OS X - Technical issue - Secure Connections (SSL/HTTPS)
bnsupport ID: 51aa0d07-cd1f-edca-db79-3acb30148126
Description:
Hi,
I installed VM OS X 64bits Multisite version 5.6 on my MAC.
Today I access the local website through the URL: http://192.168.64.4.xip.io/

I need something like: https://mysite.dev or https: //mysite.local

How should I proceed? Is there a tutorial teaching?

Hi @bygs.site,

You need to configure the domain for WP multisite. Can you check this guide:

https://docs.bitnami.com/general/apps/wordpress-multisite/configuration/configure-wordpress-multisite/#configure-the-domain-for-the-wordpress-multisite-main-blog

Regards,
Michiel

Hi Michael,
Thanks for the quick response.
I’ve seen this guide, but it talks about the need for a domain with DNS and what I want to do is just enable SSL on my MAC as localhost.

Hi @bygs.site,

You can add the ip to /etc/hosts/ to locally configure a domain.

https://osxdaily.com/2016/02/29/modify-hosts-mac-os-x-textedit/

Regards,
Michiel

Thank you very much Michael!

I configured /etc/hosts on my MAC pointing to the IP I’m using (192.168.64.4) for the bygs.site.dev domain and it worked perfectly, but I still don’t know how to enable SSL. I followed this tutorial and created the keys https://docs.bitnami.com/installer/apps/wordpress/administration/create-ssl-certificate-apache/, but I don’t know how to activate the keys?

Could you help me with that?

Hi @bygs.site,

It’s not possible to generate an SSL certificate for a domain that is not publicly accessible. Bitnami applications use a self signed certificate:

https://docs.bitnami.com/aws/infrastructure/lamp/administration/create-ssl-certificate-apache/

Regards,
Michiel

Hi Michael!

I’ll put here the step by step that I have done so far:

The domain is working perfectly, but I still receive an invalid certificate message.
Do I need to do anything else?

Regards,
Marcus

Hi @bygs.site,

Most browsers will not accept a self signed certificate as it has not been approved by a third party. I’m afraid it’s not possible to get a “secure connection” from your browser using a self signed certificate.

Regards,
Michiel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.