How can I enable wordpress multisite?

I installed my wordpress from https://bitnami.com/stack/wordpress which I could have install it from https://bitnami.com/stack/wordpress-multisite

How that I already installed the single site one, it is possible to enable multisite? I tried

/* Multisite */
define( 'WP_ALLOW_MULTISITE', true );

but it didn't work

Hello,

Please, follow the next steps to enable WordPress Multisite on your current WordPress installation:

  • First of all, make a backup of the files involved in this process, just in case (htaccess.conf may not exist):

NOTE: Please, substitute /installdir with the path where you have installed your stack. If you have launched it on a Cloud Provider, please substitute /installdir with /opt/bitnami.

cp  /installdir/apps/wordpress/htdocs/wp-config.php /installdir/apps/wordpress/htdocs/wp-config.php.backup
cp  /installdir/apps/wordpress/conf/htaccess.conf /installdir/apps/wordpress/conf/htaccess.conf.backup
  • Now, edit /installdir/apps/wordpress/htdocs/wp-config.php and add the following piece of code at the top of the file, just below the <?php header:

/** This will enable Wordpress' multisite feature */
define('WP_ALLOW_MULTISITE', true);

The top of the file will then look something like this:

<?php
/** This will enable Wordpress' multisite feature */
define('WP_ALLOW_MULTISITE', true);
/**
 * The base configurations of the WordPress.
 *

Again, make sure you leave the <?php at the top.

  • Now go to the Wordpress Dashboard, which is located at http://your_server_address/wordpress/wp-admin. Inside the Tools menu there is a new option, "Network". Click it.

  • Now Wordpress will ask you about the details of your blog network. Fill in your information and click Install.

  • At this point, Wordpress will show you a screen with instructions. Notice the two big blocks of code:

We will need them in a minute.

  • Edit /installdir/apps/wordpress/htdocs/wp-config.php, locate the line /* That’s all, stop editing! Happy blogging. */ and paste the first big block of code above it. The result should be similar to this, except for your server address which will likely be different:

define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
define( 'DOMAIN_CURRENT_SITE', '127.0.0.1' );
define( 'PATH_CURRENT_SITE', '/wordpress/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );
/* That’s all, stop editing! Happy blogging. */
  • Edit /installdir/apps/wordpress/conf/htaccess.conf (create it if it doesn't exist) add at the begining of the file the second big block of code surrounded with <Directory "installdir/apps/wordpress/htdocs"> COPY HERE THE SECOND BLOCK OF CODE </Directory> . Again, the result should be similar to this:

<Directory "installdir/apps/wordpress/htdocs">
RewriteEngine On
RewriteBase /wordpress/
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
RewriteRule . index.php [L]
</Directory>
  • Finally, edit /installdir/apps/wordpress/conf/httpd-app.conf. This file is the main application configuration file. Add here (if it wasn't) the htaccess.conf file, just writing the following line at the end of the file.

Include "/installdir/apps/wordpress/conf/htaccess.conf"
  • Restart the Apache server.

sudo /opt/bitnami/ctlscript.sh restart apache
  • Now you just have to log in again to the WordPress Dashboard (http://your_server_address/wordpress/wp-admin) and you will see a new option called "My sites" in the upper right corner:

Inside you will be able to create new sites.

Help! I followed the instructions and now Wordpress does not work! How do I restore the backup files?

  • Just copy the backup files over the modified ones.

cp  /installdir/apps/wordpress/htdocs/wp-config.php.backup /installdir/apps/wordpress/htdocs/wp-config.php
cp  /installdir/apps/wordpress/conf/htaccess.conf /installdir/apps/wordpress/conf/htaccess.conf
  • This will disable all multisite-related functionality.

Hope it helps,
Jose

2 Likes

I followed this guide, twice. And it breaks my site. All css is gone. And when I try to click on the bitnami logo at the bottom right, and click login to the site, it takes me to 127.0.0.1, and can't connect.

Also, the only place I found the folder structure that was supposed to be in htaccess.conf, is in the httpd-app.conf file. So I put the code in there. Is that an issue, since you are simply importing the code at the end of htaccess.conf anyways?

I followed this guide, and added the mysql commands like they say to do, but that didn't help.

Hi @djb,

Did you copy these lines in your configuration file or did you use the ones that WordPress showed in the admin panel?

Could you please share with us the content of the htaccess.conf and httpd-app.conf files?

In case you followed the tutorial and copied the right lines in the right files, I think you only need to configure the IP of your current site properly so you only need to follow this guide to configure it

https://docs.bitnami.com/installer/apps/wordpress/#updating-the-ip-address-or-hostname

Let us know if that fixes the issue.

Regards,
Jota

For whatever reason, the page took time to start working. But it finally loaded and worked fine. Thank you for the guide here!

Hello @djb

We are glad that you were able to fix the issue. If you have any other questions, please do not hesitate to let us know.

Best Regards,

Juan Ariza

Thanks for this Tutorial.

I followed all the steps, but when I visit my site all the CSS seems to be disabled.

Also when I try to log in I will be redirected to http://127.0.0.1/wordpress/wp-login.php.

Does anyone have an idea what I did wrong?

Best regards,
Alessio

Hi @alessio.gerbig,

Were you accessing WordPress using 127.0.0.1 before modifying the application configuration? Please note that we have this section of our documentation that explains how to set the proper IP in the database, could you please check it?

https://docs.bitnami.com/installer/apps/wordpress/#wordpress-cannot-load-images-or-css

I hope that helps.
Jota

I had the same issue and I fixed it by using phpMyAdmin (you can Google how to access it, if you need to, like I did) to edit the "wp_options" table, and update the "siteurl" and "home" options to the correct info. If you have your server set up to redirect to https, then use https in these options.

Unfortunately I encountered the same problem

Hi @hbiseeu,

Can you check our guide to configure the main site of your WordPress application?

https://docs.bitnami.com/installer/apps/wordpress/troubleshooting/debug-errors/#wordpress-cannot-load-images-or-css

Please note that you will need to set the proper URL in the "value" field of the command.

Thank you for the reply. I solved it eventually.

Hi @ all,
i made all steps and finally i have a problem that my plugin in the menu left disappeared. And i cant add new site, i see at the my sites only made site and there is no button to create new site.

Hi @a.kaufmann,

This is a quite old thread. Can you please open a new one with the detailed explanations about your issue? Our team will be glad of helping you :slight_smile:

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please download and execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code ID that is shown at the end.

Sorry for the inconveniences it may cause you,
Gonzalo