How can fix the?

Keywords: WordPress - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: b52e9737-8aee-eceb-ca80-b95ed79848d8

bndiagnostic output:

? Apache: Found possible issues
? Mariadb: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mariadb/

Description:

 ===== Begin of bndiagnostic tool output =====


    ? Apache: Found possible issues
    ? Mariadb: Found possible issues
    ✓ Connectivity: No issues found
    ✓ Wordpress: No issues found
    ? Resources: Found possible issues
    ✓ Processes: No issues found
    ✓ Php: No issues found



[Apache]

Found recent error or warning messages in the Apache error log.

[Wed Oct 13 10:41:12.036880 2021] [proxy_fcgi:error] [pid 797:tid
140313016395520] [client **ip_address**:37669] AH01071: Got error 'PHP message:
PHP Warning: Use of undefined constant ‘WP_MAX_MEMORY_LIMIT’ - assumed
'‘WP_MAX_MEMORY_LIMIT’' (this will throw an Error in a future version of PHP) in                                
/bitnami/wordpress/wp-config.php on line 216PHP message: PHP Warning: Use of
Press [Enter] to continue:
undefined constant ‘1024M’ - assumed '‘1024Mâ [Wed Oct 13 10:41:24.272803 2021]
[proxy_fcgi:error] [pid 797:tid 140312848541440] [client **ip_address**:37669]
AH01071: Got error 'PHP message: PHP Warning: Use of undefined constant
‘WP_MAX_MEMORY_LIMIT’ - assumed '‘WP_MAX_MEMORY_LIMIT’' (this will throw an
Error in a future version of PHP) in /bitnami/wordpress/wp-config.php on line
216PHP message: PHP Warning: Use of undefined constant ‘1024M’ - assumed
'‘1024Mâ [Wed Oct 13 10:41:27.616380 2021] [proxy_fcgi:error] [pid 1194:tid
140311615403776] [client **ip_address**:49767] AH01071: Got error 'PHP message:
PHP Warning: Use of undefined constant ‘WP_MAX_MEMORY_LIMIT’ - assumed
'‘WP_MAX_MEMORY_LIMIT’' (this will throw an Error in a future version of PHP) in                                
/bitnami/wordpress/wp-config.php on line 216PHP message: PHP Warning: Use of
undefined constant ‘1024M’ - assumed '‘1024Mâ\n```
Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/

[Mariadb]

Found recent error messages in the MariaDB error log:

2021-10-13 10:39:59 8 [ERROR] mysqld: Table './bitnami_wordpress/wp_usermeta' is                                
marked as crashed and should be repaired
Press [Enter] to continue:


Please check the following guide to troubleshoot MariaDB issues:

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-m
ariadb/

[Resources]

Your instance has little available RAM memory.

 total used free shared buff/cache available Mem: 1959 1400 80 107 478 276 Swap:                                
1023 2 1021

You could try to increase your instance's memory. Please check your cloud
provider's documentation for more information.


===== End of bndiagnostic tool output =====

Hi @Kalotina,

Thanks for using Bitnami. As mentioned by the bndiagnostic tool, your server is running out of free memory, what is affecting your website

-----------------------------------
Display amount of free and used memory in the system
-----------------------------------
Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:           1959        1411          84         107         463         268
Swap:          1023           3        1020

Can you increase your instance type?

https://docs.bitnami.com/aws/faq/administration/change-server-type/

Apart from that, I see some weird characters in the wp-config.php file when defining the WP_MAX_MEMORY_LIMIT setting. Can you remove them?

define( â<80><98>WP_MAX_MEMORY_LIMITâ<80><99>, â<80>**BNDIAGNOSTIC-PASS_TWO**<80><99> );

Ok :ok_hand: i fix Mariadb but the Apache has error:

cf6a9ee2-c0fa-24c5-a8f8-a0197d467303

I have one more question:
In the cotrol panel application of Bitnami the ECUs is “0”! Why is this happening?

Hi @Kalotina,

Thanks for using Bitnami. Those Apache messages are for wrong requests to your server.

[Thu Oct 14 16:38:13.915902 2021] [core:error] [pid 766:tid 140137904125696] [client **ip_address**:39204] AH10244: invalid URI path (/cgi-bin/.%2e/%2e%2e/%2e%2e/%2e%2e/etc/passwd)
 [Thu Oct 14 16:53:25.981936 2021] [core:error] [pid 766:tid 140137736271616] [client **ip_address**:36746] AH10244: invalid URI path (/cgi-bin/.%2e/%2e%2e/%2e%2e/%2e%2e/etc/passwd)
 [Thu Oct 14 21:04:05.562829 2021] [core:error] [pid 766:tid 140137711093504] [client **ip_address**:42178] AH10244: invalid URI path (/cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh)

I also see you are having a lot of requests from a few of different IP addresses.

-----------------------------------
Check performance issues: Count number of requests for the 10 most active IP addresses in the last 100.000 requests
-----------------------------------
Running: tail -n 100000 access_log | awk '{print $1}' | sort | uniq -c | sort -nr | head -n 10 | awk '{print $1}'
In: /opt/bitnami/apache2/logs/

Output:

9733
8185
2818
2037
2022
1531
1489
1072
1048
742

Can you check if there is any bot doing request to your website?

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/deny-connections-bots-apache/

:thinking: look you are right… But i dont know how to find what IP’s is…

Hi @Kalotina,

You have all the needed steps in the guide. Can you tell us in which step are you having issues?