High CPU BURST CAPACITY

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Application configuration

bnsupport ID: d59ecc1e-bb16-8994-3315-c749c09b90f6

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
Hi,

My CPU Burst Capacity is very high. How can I reduce ti?

Also to generate the support tool code, i had to stop the ctlscript and then generate the code. Hence you may see the errors.

Hi @huzanforbes,

Thanks for your message. I understand the high value for this parameter is caused by the high usage of your server resources. I see you have many different websites in your apache2/htdcos folder, which may cause many processes are run on your server at the same time, plus a couple of cron jobs being executed every 2 hours.

I think this is the cause of your issues, but you can confirm this with the help of the AWS Lightsail support team, who I also think may be able to provide you with some tips on this.

Maybe using other non-lightsail instances (like regular EC2 instances) is an option to avoid these errors, but I’m not sure about that.

Hi @gongomgra

My websites are not that traffic heavy. All websites combines it would be around 200 visits a month. Is this too much as traffic?

Hi @huzanforbes,

Thanks for your message. I reviewed your bnsupport bundle again and I still think CPU issues are caused by the requests you are getting or the plugins you have installed in your websites. If they are interacting with the database, it can be consuming CPU cycles that are affecting your burst capacity.

These are the requests I see in the bndiagnostic information

-----------------------------------
Check performance issues: Count number of requests for the 10 most active IP addresses in the last 100.000 requests
-----------------------------------
Running: tail -n 100000 access_log | awk '{print $1}' | sort | uniq -c | sort -nr | head -n 10 | awk '{print $1}'
In: /opt/bitnami/apache2/logs/

Output:

4900
170
136
93
52
40
34
34
30
30

I may be wrong, but if I recall it correctly, every visit to your website launches the wp-cron.php internal process from WordPress directly, which will also consume CPU credits to be run. Can you double-check this in the official WordPress forum or docs?