Help to install SSL certs from WP-Encrypt on Virtual Machine Wordpress Bitname

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?:

I’m using the latest version (bitnami-wordpress-4.8-0-linux-debian-8-x86_64)

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX):

Running on a Dedicated SoYouStart (OVH Sub-brand) on ESXi 6.5.

  • Have you installed any plugin or modified any configuration file?:

Yes, Installed the WP-Encrypt by following doc on your site.

  • Describe here your question/suggestion/issue (expected and actual results):

I tried installing the SSL Certificate that WP-Encrypt created, but had issues, the server still load the Self-signed Cert. It just doesn’t work. Any help would be appreciate!!

  • Steps to reproduce the issue (if relevant):

You can see the issue by going at https://arts20.com (it will show the self-signed cert).

  • Copy the apache log (if relevant):
PASTE HERE

Hi @pducharme,

Thank you for using Bitnami. Could you please give us more details on the way you are configuring the certificates in your server?

Once you generated the certificate with WP-Encrypt plugin, you need to configure Apache to use those certificates. Did you follow all the steps detailed in our guide How To Enable HTTPS Support With SSL Certificates?. Is there any step that you are not able to complete?

We’ll be looking forward to receiving your reply.

Best regards,
Andrés Bono

I tried following the doc, but none of the cert files I get from the WP-Encrypt plugins are the same. Here is a pic of what I have for certs files :slight_smile:
http://take.ms/y151K

Hi @pducharme,

Were you able to solve the issue? By accessing to your site, it shows a valid SSL certificate :thumbsup:

Best regards,
Andrés Bono

@pducharme As you noted, the WP-Encrypt plugin creates differently named files, but the necessary files are all there. It took me a while, but I figured out what they were.

Check out the solution in this thread: