Hello ever since using Bncert my server and pagespeed have a lot of issues

Keywords: WordPress - AWS - Technical issue - Other

bnsupport ID: d0f593b3-1d51-20cd-4cb8-e454284767e7

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Php: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/administration/use-pagespeed/#disable-pagespeed
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/
https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
Hi i am using wordpress on aws lightsail bitnami apache server. I created SSL certificate for my website using sudo /opt/bitnami/bncert-tool. Ever since then i have several issues:

  1. Pagespeed has stopped working, i would love to still work - my images are no longer being compressed. i get those errors: PageSpeed Serf fetch failure rate extremely high
  2. it seems to now be using http1.1 instead of 2??
  3. I am also getting those errors:
    AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

Please help!

Hello @dorishchitson,

Your issues are most likely related to insufficient memory in your instance, which is producing the timeouts in PageSpeed and redirects:

-----------------------------------
Display amount of free and used memory in the system
-----------------------------------
Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:           1995        1080         104         170         811         570
Swap:             0           0           0

You can increase your instance size by increasing your instance size.

Regards,
Francisco de Paz

Are you sure about this? It was working fine before. The only thing that changed is adding the SSL Certificate.

Hello i can’t make that link that you gave me work. please note am using aws lightsail. also i created a snapshot and used in a 4GB Ram instance:

free -m
              total        used        free      shared  buff/cache   available
Mem:           3947         638        2874          56         434        3043
Swap:          1023           0        1023

there’s still 3GB available and still no pagespeed compression. Can you please check my configuration files?

also i did this:

  curl -D- http://mydomain.com | less

and i don’t see the X-Mod-Pagespeed:xxx entry.

Any help please?? i upgraded to a larger instance and i don’t see any evidence of pagespeed working.

Asking again. Need help with pagespeed. It stopped compressing images ever since i installed SSL via bncert tool. I upgraded my instance to 4GB and still issues

asking for the 4th time. if you are unable to assist please refer me to someone who can. thank you.

Hello @dorishchitson,

Sorry about the wait. Pagespeed is known to be problematic and to cause issues sometimes, some of those being it does not work in all cases. We have in our to-do list to investigate further, but we haven’t started yet so it may take some time until it is resolved.

In your case, it could be either Pagespeed malfunctioning, or some resources being broken on your side. See this for more info: https://www.modpagespeed.com/doc/faq#warning-fetch-rate . You may want to check if it could be possible the second case is happening.

I’m also seeing that your site is using Cloudflare, which could be causing the issues in PageSpeed, as you are using an external endpoint to access your site. Did you have enabled Cloudflare and PageSpeed working properly at some point or did you enable it when you introduced SSL?

Another point that could be causing issues is that you have a no-cache policy configured in your site, which could be affecting PageSpeed:

$ curl -LI yourdomain.com

...
cache-control: max-age=0, no-cache
cf-cache-status: DYNAMIC
...

Could you try removing those headers?

Regards,
Francisco de Paz

It stopped working before i added cloudflare as far as i remember. how do i remove the headers that you mentioned? sorry am not a website or bitnami expert.

Hello can you tell how to remove the no-cache policy for cache-control? i idid not specifically change this. it seems it was automatically configured that way.

Hi @dorishchitson,

I can see that you are using optimization plugins like Autoptimize (https://wordpress.org/plugins/autoptimize/) that can configure the cache policies in the application Please note that those cache configuration may be set by the application itself. You can try to disable the plugins/themes you installed to see if the cache-control configuration changes. However, if you continue running into issues, please note that Pagespeed can conflict with the application/plugins/themes and maybe it’s better to disable it. Please note that if you are using Cloudflare you can proxy the requests through it to improve the performance of the responses.

Thanks so i turned off and deleted auto optimize. i still do not see or have any idea if pagespeed is working. any help there?

Hi @dorishchitson,

this guide explains how to get statistics from PageSpeed

https://docs.bitnami.com/aws/apps/wordpress/administration/use-pagespeed/#check-pagespeed-statistics

I tried that and it did not work. A lot of the bitnami docs recommendations i have tried seem to be outdated.

can you send instructions that actually work? this is getting extremely frustrating.

Hi @dorishchitson,

I just followed the instructions and confirmed that PageSpeed is working properly in my instance

I understand you didn’t edit the pagespeed.conf file properly and that’s why you can’t access it. Mine looks like this, what about yours?

...
    <Location /pagespeed_admin>
      <IfModule mod_rewrite.c>
        RewriteEngine Off
      </IfModule>
        Order allow,deny
        Allow from localhost
        Allow from 127.0.0.1
        Allow from MY_IP
        SetHandler pagespeed_admin
    </Location>
    <Location /pagespeed_global_admin>
      <IfModule mod_rewrite.c>
        RewriteEngine Off
      </IfModule>
        Order allow,deny
        Allow from localhost
        Allow from 127.0.0.1
        Allow from MY_IP
        SetHandler pagespeed_global_admin
    </Location>
...

Please note that you need to replace MY_IP with your public IP address. You can get it from http://myip.bitnami.com

I’ll notify our documentation team to update the guide to remove the mentions to pagespeed_console, mod_pagespeed_message and mod_pagespeed_statistics.