Has anyone been able to install Canvas Analytics on Bitnami Canvas?

Keywords: Canvas LMS - AWS - How to - Other
Description:
The repo for the analytics package is here: https://github.com/instructure/analytics

I’ve been working on trying to install it to work with our Bitnami Canvas instance on AWS, but I seem to be having trouble everywhere I turn. Has anyone successfully installed analytics? Any advice would be appreciated. Thanks in advance.

Hello @jacobryas4,

Could you please take a look at this case?

I hope it helps

Hi,

This is not very helpful , I am trying to follow this and ending with lots of errors in bundle update and my canvas stop working after running all commands as per this document.

I am facing problem after running these command below before running bundle update .
bundle lock --add-platform ruby
bundle lock --add-platform x86_64-linux

Does any one get success and able to see course analytics in canvas and working fine by following this document ?

If yes can some on please suggest why bundle update is not successful in my case ?

Hey @davidg,

Thanks for the reply. I’ve taken a look at that thread but OP never responded to let us know if it worked or not.

I’ve been looking all over the forums here and else where and I haven’t been able to find anyone who can confirm that they were able to install Canvas analytics on the Bitnami Canvas image. I was looking for anyone who has done it successfully so that maybe they could shed some light on the process. This made me wonder as to whether Bitnami Canvas is compatible with the analytics repo.

The steps given in the repo to install seem simple, but the process always breaks our instance of canvas and it is very difficult to find out why.

If anyone has any additional info it would be much appreciated

Hi @arcmalik5358,
Here are more detailed instructions for the steps @davidg indicated in the link.
In the cassandra server, you will need to open the ports to the canvas server,
then connect to it and create the keyspaces:

# cqlsh -u cassandra 
CREATE KEYSPACE page_views WITH REPLICATION = { 'class' : 'SimpleStrategy', 'replication_factor' : 1 };
CREATE KEYSPACE page_views_test WITH REPLICATION = { 'class' : 'SimpleStrategy', 'replication_factor' : 1 };
CREATE KEYSPACE auditors WITH REPLICATION = { 'class' : 'SimpleStrategy', 'replication_factor' : 1 };
CREATE KEYSPACE auditors_test WITH REPLICATION = { 'class' : 'SimpleStrategy', 'replication_factor' : 1 };

Latter, in the canvas server:

$ sudo su -
# cd /opt/bitnami/apps/canvaslms/htdocs/config

You need to create a file for the cassandra connection like the following one. Replace 127.0.0.1 with the IP / hostname of the cassandra server.

# vi cassandra.yml
development:
  page_views:
    servers:
    - 127.0.0.1:9160
    keyspace: page_views
  auditors:
    servers:
    - 127.0.0.1:9160
    keyspace: auditors
test:
  page_views:
    servers:
    - 127.0.0.1:9160
    keyspace: page_views_test
  auditors:
    servers:
    - 127.0.0.1:9160
    keyspace: auditors_test

The you need to install the plugin. What I did was:

# cd /opt/bitnami/apps/canvaslms/htdocs
# git clone https://github.com/instructure/analytics gems/plugins/analytics
# mv Gemfile.lock Gemfile.lock.old
# mv .bundle/ .bundle_bak
# bundle update
# RAILS_ENV=production bundle exec  rake db:migrate
# RAILS_ENV=production bundle exec  rake canvas:compile_assets

Restart the services:
# /opt/bitnami/ctlscript.sh restart

I hope this helps

Hello rafaelrios,

Thank you so much for the reply . I tried to run all the command as you suggested on Canvas. Cassandra was installed on the same server after running bundle update command I end up with following error :

root@ip-172-31-30-160:/opt/bitnami/apps/canvaslms/htdocs# bundle update
Fetching https://github.com/rails-api/active_model_serializers.git
git: ‘/opt/bitnami/ruby/lib/ruby/gems/2.4.0/cache/bundler/git/active_model_serializers-510a178f5743dd588f54b8591fd82d287cfc711e’ is not a git command. See ‘git --help’.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Retrying git clone --no-checkout --quiet "/opt/bitnami/ruby/lib/ruby/gems/2.4.0/cache/bundler/git/active_model_serializers-510a178f5743dd588f54b8591fd82d287cfc711e" "/opt/bitnami/ruby/lib/ruby/gems/2.4.0/bundler/gems/active_model_serializers-61882e1e4127" due to error (2/4): Bundler::Source::Git::GitCommandError Git error: command git clone --no-checkout --quiet "/opt/bitnami/ruby/lib/ruby/gems/2.4.0/cache/bundler/git/active_model_serializers-510a178f5743dd588f54b8591fd82d287cfc711e" "/opt/bitnami/ruby/lib/ruby/gems/2.4.0/bundler/gems/active_model_serializers-61882e1e4127" in directory /opt/bitnami/apps/canvaslms/htdocs has failed.
If this error persists you could try removing the cache directory '/opt/bitnami/ruby/lib/ruby/gems/2.4.0/cache/bundler/git/active_model_serializers-510a178f5743dd588f54b8591fd82d287cfc711e’git: ‘/opt/bitnami/ruby/lib/ruby/gems/2.4.0/cache/bundler/git/active_model_serializers-510a178f5743dd588f54b8591fd82d287cfc711e’ is not a git command. See ‘git --help’.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
Can you please suggest me why I am getting this error every time when I try to run " bundle update" command .

Hi @arcmalik5358,
Did you tried what the git command suggested ?

and then try to do the bundle update again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.