GTmetrix Grade low on Bitnami / Lightsail AWS website

Keywords: WordPress - AWS - Technical issue - Other

bnsupport ID: db59fcf1-14d5-3cce-ffeb-1c96bf1ac9a2

bndiagnostic output:

? Apache: Found possible issues
? Mysql: Found possible issues
? Php: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/disable-binary-logging-mysql/
https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
Hello I have two issues I want to learn how to fix,

  1. How to Enable Keep-Alive

  2. Serve static assets with an efficient cache policy

https://gtmetrix.com/reports/naturesanswer.com/sdaZTAGm/
This is the link to my GTmetrix grade and I am having issues with CACHE TTL aswell as Enabling Keep-Alive.

I have followed previous instructions on Bitnami Forms and adding the Enable Keep-Alive to my file in cd /opt/bitnami/apache2/conf/bitnami/

then I went into httpd-xlarge.conf, using vim httpd-xlarge.conf

added the enable keep alive but still no help on the issue.

https://www.naturesanswer.com/wp-content/uploads/2021/02/Kosher62994E.png
https://www.naturesanswer.com/wp-content/uploads/2021/02/Vegan62994E.png

But these two URLS will not stop appearing.

Screen shot of the TTL CACHE that needs to be enabled or turned on.

Screen shot of the urls that keep coming up and stating there is no Keep-Alive enabled.

Hello @rpak,

Could you please take a look at our optimization guide for WordPress in order to improve the performance?
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/optimize-bitnami-wordpress/

Please let us know if it helps

I am using a premium plug in wp-rocket already with they settings they told me.

How do I Enable Keep-Alive for bitnami aswell as Serve static assets with an efficient cache policy, I have tried everything and even using wp-rocket cache plug in.

Please help

Hello @rpak,

Your server has KeepAlive active as can be checked in /opt/bitnami/apache/conf/extra/httpd-default.conf or using a simple web to check this: https://technumero.com/keep-alive-test/

The issue seems to be only with those 2 images. When trying to access either one of them, I get a 503 error from Wordfence, which may be triggering the false positive on the metrics page.

Regarding the cache configuration, we can’t give you a detailed answer on this, as it goes beyond our area of expertise. I suggest you to check again with wp-rocket developers so they fine-tune the recommended configuration or trying using another cache-elated plugin we list in the guide my colleague shared previously.

Regards,
Francisco de Paz

my other site also has file caching headers enabled while this bitnami hosted website does not

Any help? on request

Hello @rpak,

It looks like the keep-alive configuration is incomplete by default. Although it is true the keep-alive configuration can be found at /opt/bitnami/apache/conf/extra/httpd-default.conf, you need to enable said file and its header. For that you need to uncomment the Include line at /opt/bitnami/apache2/conf/httpd.conf and configure its header in the same file:

...
<IfModule headers_module>
    #
    # Avoid passing HTTP_PROXY environment to CGI's on this or any proxied
    # backend servers which have lingering "httpoxy" defects.
    # 'Proxy' request header is undefined by the IETF, not listed by IANA
    #
    Header always set Connection keep-alive
    RequestHeader unset Proxy early
</IfModule>
...
# Various default settings
Include conf/extra/httpd-default.conf

Regarding the issue with the images, it could also be a case of broken links. There some plugins to help you find and fix these links like Broken Link Checker though I recommend you to ask for a more detailed recommendation on this in WordPress official forums.

Regards,
Francisco de Paz