Get this error "Error establishing a database connection" every time I try this "

The connection “forWP” and the schema inside it was created by me. New Wordpress installation didn’t create it.

Hi @hmashwinkumar,

Thanks for your message. I’m afraid I’m getting a bit lost here. Let me ask you some questions to get more context and try to help.

Did you install the stack again using a simple password as suggested? Which application is the one in which you created the forWP view? Which schema did you create? Is the bitnami_wordpress database populated? It should have been as part of the Bitnami installation. Does the WordPress application work?

Have created separate connection for Wordpress and it is working fine

Can you tell us why do you need this connection? Is that needed for a custom process? The WordPress application should be working correctly right after the installation process without the need of doing any other modification to its internal config.

Hi @gongomgra, First and foremost - Thanks a lot for answering all my question with patience :slight_smile: Hopefully we will have some breakthrough soon.
Here are the answers to your questions -

Did you install the stack again using a simple password as suggested?
I ran this file for installing. It didn’t prompt for any password during the installation - “bitnami-wordpress-5.7.1-0-windows-x64-installer.exe”
Which application is the one in which you created the forWP view?
I used Workbench for creating this.
Which schema did you create?
By Schema I meant in Workbench terms. Meant that I created bitnami_wordpress.
Is the bitnami_wordpress database populated?
No. It is not populated as I created it manually.
Does the WordPress application work?
This link does not work - get this error - image

I am unable to figure out way for setting the password for “forWP” instance. Do we have option to do this? If I change password will that change in other connection as well? image

Hi @hmashwinkumar,

Thank you for your message, then I think the installation went wrong. Creating a database manually, or the MySQL schema in workbench is not needed for WordPress to work properly. The installation process should take care of populating the database and configuring the application.

Did you get to a windows like the one below at the beginning of the installation process? It is to create the application default username and credentials

We released a new revision of our WordPress installers recently, can you use it? New version is 5.7.1-1 instead of 5.7.1-0

Uninstall you current stack and install the new one. Do you get any error message? Can you check the installation logs? Only check the most recent file please

If you keep having issues to access WordPress after that, can you start the Bitnami console as explained below?

Once you have it, please run the next command and share the result with us. It will prompt you for the password you set in the installation process (my screenshot above)

mysql -u root -p -d bitnami_wordpress -e "show tables;"

Can you also check you aren’t having issues with the anti-virus or the firewall?

Hi @gongomgra, I remember seeing this form during my first installation. Didn’t see this while installing later. Can you please let me know if uninstalling this will suffice or if I have to do something else?

Hi @hmashwinkumar,

You can run the “uninstaller.exe” program from the installation directory. It will take care of removing all the files in the installation and clean the system services. You will need to restart the computer afterwards for changes to take effect.

Thanks, @gongomgra
I will run this file instead of uninstalling from Programs - image
Will let you know how it goes.


Hi @hmashwinkumar,

Yes, run that program and once it finish please restart your computer. After that install WordPress version 5.7.1-1 from our website (or the most recent one if any) and let us know if you get any error during the installation process. In case you don’t, you should be able to see your WordPress website by browsing to