Generation of log files only works if --set postgresqlImage.debug=true is set

Keywords: PostgreSQL - Other - Technical issue - Other
I have a general postgresql-ha setup issue, using the following command.

helm install $deployname bitnami/postgresql-ha --set postgresql.configurationCM=postgres --set postgresqlImage.debug=false

I have noticed that the log entries from the postgres-postgresql-ha-postgresql-0 and 1 are completely missing. However if I enable the --set postgresqlImage.debug=true flag to true. The logs are written correctly. This can be verified using the kubectl logs postgres-postgresql-ha-postgresql-0 command. if the debug flag is set to true, only messages from the replication manager is shown.

My assumption would be that reading log files from postgresql should not require the debug=true flag to be set, is this the correct expected behavior? or is there a bug or something i have missed?. If so, what would be the correct approach to extract logs from postgresql using the bitnami helm chart?

Hi @jebru,

We handle questions regarding our Helm charts on Github. Could you ask your question there?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.