GCP Odoo Server connectivity issue after changing postgresql user passwords

Keywords: Odoo - Google Cloud Platform - Technical issue - Other
bnsupport ID:
2c5068ff-dda3-2281-60f3-ffc94722c217
Description:
Hello,

I recently was trying to connect Google Sheets to our GCP VM Odoo 14 server and still haven’t figured out how to do it after much research. Along the way, I reset the postgresql user passwords for both postgres and bitnami_odoo dbs for users postgres and bn_odoo. Everything was working fine last night when I left but today I was unable to connect to the server and received the following error:

“Internal Server Error
The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.”

I am still able to SSL in and manage the instance on GCP. I just started logging for the VM on GCP and see an error:

“Exception: Address unavailable: http://[my vm IP]/web/session/authenticate”

I also see that there is a Bitnami Support Tool Bundle on my VM and it is the current version though I do not know what to do next.

This is our live db vm for our company so it is an urgent issue and believe that I am a bit nervous!

Can someone help me understand what is going on and/or troubleshoot?

Thank you so much for your help!

Hi @sw_365

Thanks for using Bitnami Odoo!

I recently was trying to connect Google Sheets to our GCP VM Odoo 14 server and still haven’t figured out how to do it after much research. Along the way, I reset the postgresql user passwords for both postgres and bitnami_odoo dbs for users postgres and bn_odoo.

From what you mention and the report generated by bnsupport-tool, I think Odoo is failing to connect to the database and thus you are obtaining that error as a result. Furthermore, this is what the PostgreSQL’s log looks like:

...
2021-02-26 00:44:17.327 UTC [19537] FATAL:  password authentication failed for user "bn_odoo"
2021-02-26 00:44:17.327 UTC [19537] DETAIL:  Password does not match for user "bn_odoo".
        Connection matched pg_hba.conf line 90: "host    all             all             127.0.0.1/32            md5"
2021-02-26 00:44:28.939 UTC [19538] FATAL:  password authentication failed for user "bn_odoo"
2021-02-26 00:44:28.939 UTC [19538] DETAIL:  Password does not match for user "bn_odoo".
        Connection matched pg_hba.conf line 90: "host    all             all             127.0.0.1/32            md5"
2021-02-26 00:45:07.333 UTC [19718] FATAL:  password authentication failed for user "bn_odoo"
2021-02-26 00:45:07.333 UTC [19718] DETAIL:  Password does not match for user "bn_odoo".
        Connection matched pg_hba.conf line 90: "host    all             all             127.0.0.1/32            md5"
...

In order to solve this, provide the new password for the bn_odoo user in the Odoo configuration file /opt/bitnami/apps/odoo/conf/odoo-server.conf:

[options]
...
+ db_password = PASSWORD-HERE
db_user = bn_odoo
dbfilter = .*

Source: https://www.odoo.com/documentation/14.0/setup/deploy.html#id3

After that, you may restart the services and retry:

$ sudo /opt/bitnami/ctlscript.sh restart

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

1 Like

Jose, you guys are seriously the best! That worked perfectly.

Thank you so much! and for the fast reply as well -

My pleasure!

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing to this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

1 Like