File Upload Limit in php.ini unchanged

Keywords: Moodle - Google Cloud Platform - Technical issue - Other
Description:
https://docs.bitnami.com/aws/apps/wordpress/administration/increase-upload-limit-php/

I have changed those settings in php.ini:

max_execution_time: 600
post_max_size: 500M
upload_max_filesize: 500M

After restarted apache, i check the phpinfo at https://www.urdomain.com/admin/phpinfo.php

post_max_size and upload_max_filesize is showing 80M

Also, i checked in Moodle - Administration - Courses - Course default settings

Maximum upload size moodlecourse | maxbytes

Site upload limit (80MB)
Default: Site upload limit (80MB)

Is there any extra config I need to edit beside php.ini ?

Hi @ke11,

You need to restart the PHP-FPM service

sudo /opt/bitnami/ctlscript.sh restart php-fpm

Happy to help!


Was my answer helpful? Click on :heart:

sudo /opt/bitnami/ctlscript.sh restart php-fpm
sudo /opt/bitnami/ctlscript.sh restart apache

I have restarted both services, but phpinfo still showing 80M for both values.

Hi @ke11,

I just noticed that the Bitnami Moodle solution has some values duplicated in the php.ini file. For example, the upload_max_filesize and post_max_size parameters are duplicated in the file so you need to remove one of the entries or ensure they both have the same value in the conf file. Once you modify the php.ini file, restart the services and access the phpinfo.php website again


Above is my phpini config, i have changed both values and restarted both php-fpm and apache, phpinfo it keep showing 80M which is the default setting


only 80M setting

I solved.

The Local Variables at the end of the phpini overwrite the settings.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.