Failed to renew certificate in bncert-tool

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Secure Connections (SSL/HTTPS)

bndiagnostic ID: f5fdb65b-e982-f073-8c6d-ddbb886efda8

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Processes: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I’m using AWS Lightsail with Bitnami LAMP

I didn’t really used my server for some months and then someday i fond the ssl certificate is expired.

when i ran the bncert it told me i need to update, and after update it failed by telling me “Error while revoking the certificate for domain”

But when I try to revoking manually it says “Certificate is expired”

I didn’t find any useful message in the diagnostic tool, or maybe i just missed something.

Or maybe its because of another problem? i’ve uploaded the logs by Diagnostic tool.

Any help is appreciated, thanks.

Hi @lorddoomed,

The cronjob is disabled and that’s why the certificate was not renewed

sudo crontab -l -u bitnami

What about if you ty to manually create it again?

sudo /opt/bitnami/letsencrypt/lego --path /opt/bitnami/letsencrypt --email="XXXXXXpapa@gmail.com" --http --http-timeout 30 --http.webroot /opt/bitnami/apps/letsencrypt --domains=catxpapa.com --domains=catcolate.com --domains=www.catcolate.com  --domains=www.catxpapa.com run

If the certificates are generated properly, please restart Apache and enable the cronjob.

Thank you, it looks almost there, but here’s some 404 Not Found problem on .well-known directory now, guess I made some mistakes in the vhost confs?

2022/01/17 09:55:00 Could not obtain certificates:

error: one or more domains had a problem:

[catcolate.com] acme: error: 403 :: urn:ietf:params:acme:error:unauthorized :: Invalid response from http://catcolate.com/.well-known/acme-challenge/3EHPPC805qOIeJAh-_C22FOcA1ds5UGy4W4Uj-65iYg [3.67.46.160]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>404 Not Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

[catxpapa.com] acme: error: 403 :: urn:ietf:params:acme:error:unauthorized :: Invalid response from http://catxpapa.com/.well-known/acme-challenge/44tQe-k4RwDN66wy2XfOICsT66b5l8j1MxC9PrWWke4 [3.67.46.160]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>404 Not Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

[www.catcolate.com] acme: error: 403 :: urn:ietf:params:acme:error:unauthorized :: Invalid response from http://www.catcolate.com/.well-known/acme-challenge/y5-OG_7TSfA5yc0t50Nrqjxwmb-NUALTkh-ryNvS4e0 [3.67.46.160]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>404 Not Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

[www.catxpapa.com] acme: error: 403 :: urn:ietf:params:acme:error:unauthorized :: Invalid response from http://www.catxpapa.com/.well-known/acme-challenge/iCi7mjjJ7oWoaF8jflMLNwIaav0W9sSE0LNgTpE4IVQ [3.67.46.160]: "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>404 Not Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p"

Hi @jota , could you help me with the problem above again?
Please, i have no idea what’s it meaning…

Hi @lorddoomed,

Can you try the alternative approach?

https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#alternative-approach

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.