EXO Platform 4.4 search Wiki Issue

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?: bitnami-exoplatform-4.4.0-1-linux-debian-8-x86_64.ova

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX): Imported bitnami-exoplatform-4.4.0-1-linux-debian-8-x86_64.ova to VMware ESXI

  • Have you installed any plugin or modified any configuration file?: No

  • Describe here your question/suggestion/issue (expected and actual results):
    I am getting 0 Results for everything I search for in my Wiki Pages. Other Searches under Documents works fine.
    I note a large amount of indexing operations relating to Wiki-page in Index Search Management Application.
    While other operations seem to proceed and disappear, all wiki-page operations seem to have stalled
    363 wiki-page null DELETE_ALL undefined
    364 wiki-page 1 CREATE undefined
    365 wiki-page 2 CREATE undefined
    etc

  • Steps to reproduce the issue (if relevant):
    Search for a Wiki Page and you will get 0 results

  • Copy the apache log (if relevant):

PASTE HERE

Hi @jasonvkeane,

We’ve been able to reproduce the issue and we are investigating it. Thanks for reporting.

Regards
Michiel D’Hont

Thanks for the reply Michiel,
What generally happens now ? Does someone investigate and come back to me with a solution or is the solution built into a future build ?
For me the server is pretty much useless without a Wiki Search feature

Hi @jasonvkeane,

We will notify you when the fixed stack is available for download. My apologies for not mentioning that. :slight_smile:

Regards,

Michiel D’Hont

Great, thanks Michiel

Hi,

Just wanted to let you know that we released a new revision of eXo Platform fixing this issue.

Fixing current installations is pretty straightforward:

  • Open INSTALLDIR/apps/exoplatform/gatein/conf/exo.properties.

  • Remove the following line:

      exo.es.embedded.enabled=false
    

    And this one as well:

      exo.es.indexing.replica.number.default=0
    
  • Restart your services:

      INSTALLDIR/ctlscript.sh restart
    

Best regards,
Marcos