Eventos CRON de mi web No funcionan error 503 / AWS / WordPress Certified by Bitnami

Keywords: WordPress - AWS - Technical issue - Other
bnsupport ID: 53ff6497-7a83-29fe-4562-d2354f6499f5
Description:
I have performed a review of my website as I have noticed something weird that I don’t think is normal. When a user registers to me as ADMIN, it changes the name and ID of my WordPress account by the data of the user who has not even activated his account yet.

At first, I thought it was a hack or something like that, but after doing some research on my WordPress, I realized that every cache plug-in I installed gave me a CRON error, that it didn’t work, that something happened and so on.

Wp Rocket programmers told me that I should contact the server or instance administrators, AWS told me to contact Bitnami and here I am asking for your help, because I do not know what is this error that the CRON does not work, and I change only the name and Admin ID for the data of users who just registered or are registered every time they log in, or I log in to my website.

Any solution to this problem, because I tried to change the Instance, but when I back up the site I get the error with everything?



I attach a screenshot of what I get in the CRON event plug-in, and I also attach a screenshot of what I get in the wp rocket cache plug-in when I try to use it, even when I try to make backups I get an error so nothing works I do not know why if everything was fine.

Outside and inside it works fine, but in terms of programming and functions it is not worth anything, I don’t know why, any solution?

Hi @carbo17,

I just launched a fresh Bitnami WordPress instance and got no errors when installing and using the WP-Control plugin.

Let’s try to run the wp-cron.php script manually to see if it returns any problem. Can you run these commands?

sudo su daemon -s /bin/sh -c "cd /opt/bitnami/apps/wordpress/htdocs/; /opt/bitnami/php/bin/php wp-cron.php"

Does it return any error? Were the jobs updated in the Cron Events menu of the WordPress dashboard?

Captura

Nothing came out, I don’t know if it is because the path of the command that you sent me is the path of the new instance, I haven’t updated it yet. What would be the correct path for the old instance in case that is the problem that the command does not run well.

Hi @carbo17,

Let’s try with another method to run the cron jobs, what’s the output of this command?

wp cron event run --all

Were the jobs updated? I also created this sample cron event in the WordPress dashboard to create a new file in the /tmp folder

$myfile = fopen("/tmp/newfile.txt", "w") or die("Unable to open file!");
$txt = "John Doe\n";
fwrite($myfile, $txt);
$txt = "Jane Doe\n";
fwrite($myfile, $txt);
fclose($myfile);

Once I ran the cron job, the file was created successfully

$ cat /tmp/newfile.txt
John Doe
Jane Doe

Can you try to reproduce this?

The edit cron option does not appear as in the image.

I don’t understand this question?

Hi @carbo17,

You need to create a new event and select PHP script as event to create. Then you need to add the code I posted in my previous message.

I asked you to run this command in the instance and post the output here

wp cron event run --all

I have done the steps you indicated and this is what came out in the terminal and in the web page.



Captura

image

Here I ran the command outside of root and got this


I would like to comment that out of the blue the date of the cron event was changed, which I believe was set at 51 years.

Hi @carbo17,

It seems there is a problem with WordPress and the cron jobs and they can’t be run. We tried different options but they do not seem to work. Can you contact the WordPress support team to get more information about the issue?

https://wordpress.org/support/

I do not know what’s happening here. I understand the date in the instance is correct (you can run the date command in the instance) but the cron jobs in WordPress are not properly configured. The WordPress support team will probably provide you more information about what’s happening here.

You can also contact the plugin’s developers to know what happening there

https://wordpress.org/support/plugin/wp-crontrol/

It seems there was a similar problem in the past

https://wordpress.org/support/topic/add-new-cron-job-error/

Ok ready right now I contact them because if the problem is rare.