ETag and htacess issues

Hi,

I’ve installed LAMP stack with the Wordpress Module.

I want to remove ETag in the server response header. For that I have added the following lines in my root .htaccess, right below the wordrpess lines.

Header unset ETag
FileETag None

This had no effect. I tried above … same result

Then I tried in the httpd-app.conf and it worked !

Why would it be working in the httpd-app.conf and not in the .htaccess file ?
Tks

Hi @da_chinese,

This is due to the AllowOverride None Apache option. For security and performance, we disable .htaccess files in our stacks, and move its content to htaccess.conf file. You can see more information about this in the following link:
https://docs.bitnami.com/installer/components/apache/#how-to-configure-htaccess-files

I hope it helps

1 Like

Thanks a lot ! I didn’t know that and that would explain it :slight_smile:

Thanks for the link and the good work @bitnami !!!

Hi,

We are glad that you were able to fix the issue.

Best regards,
Silvio Fernández

Hey there, I’m having the opposite issue actually with a bitnami stack for lightsail. So I’ve imported a site that before was using the htacess file and it seems that despite bitnami disables it by default, importing the website has overriden this? Despite checking all .conf files (including the apache conf file) all OverrideAll sections are set to none, yet it’s still looking for an htacess. PLEASE HELP!!

Lightsail → Bitnami Stack

Hello @askmarkvee,

This case is really old. New cases are automatically closed, but previous cases are still open. Could you please create a new case with more information about the issue you are facing? There, you can share the results of the support tool with us.

Regards