Error while installing AkeneoWooCommerceConnector bundle

Keywords: Akeneo - Virtual Machines - Technical issue - Other
bnsupport ID: 1bb6286b-6b2a-1678-351e-53c9c681377c
Description:
I am following instructions from here https://webkul.com/blog/woocommerce-akeneo-pim-connector/ to install the AkeneoWooCommerceConnector bundle (section “Installing Module for Version 4.0.x”).

Copying the bundle files to /src and /config as well as adding the bundle to /config/bundles.php works. Also, the command to clear the cache (sudo php bin/console cache:clear --env=prod;) works. Note that I added sudo.

However, the subsequent command sudo php bin/console woocommerce:setup:install --env=prod; (I again added sudo) errors out with:

/bin/sh: 1: webpack: Permission denied
error Command failed with exit code 126.
/bin/sh: 1: webpack: Permission denied
error Command failed with exit code 126.

I execute commands in directory /home/bitnami/apps/akeneo/htdocs

Any help is very much appreciated. Thanks a lot!

Hi @packraftch

Thanks for using Bitnami Akeneo!

Unfortunately, we don’t have a guide covering that topic so I can’t provide you with detailed steps. From the error above, it clearly seems to be a permissions issue, but with so little verbosity I can’t tell which directory it refers to.

Are there any more details the command is logging? In this case, I would recommend reaching out to the original guide or developer of the plugin, they will probably have a better understanding of the things running under the hood.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi Jose
Thanks a lot for your reply. I got some help from developers and they advised me to make sure Webpack is installed:

npm install --save-prod webpack
npm install

This was successful.

However, when I now execute the command php bin/console woocommerce:setup:install --env=prod; again, I get the following errors:

(unfortunately, I don’t know how to scroll up in this console to see the beginning :expressionless:)

I have again uploaded diagnostics data: a23aed47-5b3d-6918-67be-82b75a4960d5

Thanks a lot for your help!

Best regards,
Iwan

Hi @packraftch

My pleasure!

From the errors in your console, it seems like you need to install more modules (apart from webpack), such us one named colors. You may try installing the missing modules and resort to the developers for further advise if it does not resolver the issue.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona
That was helpful. Besides colors there were a few other modules missing, also webpack-cli. I installed modules with npm install <module>.

Now, when running php bin/console woocommerce:setup:install --env=prod; I get the following error:

There seems to be some incompatibility between module versions. Any advice on how I can find out/resolve?

Thanks a lot for your help and best regards,
Iwan

Hi @packraftch

This time I don’t have any suggestions on how to solve the issue. I also agree it seems to be an incompatibility between versions. Some other people has also experienced this error on different assets:

https://github.com/framework7io/framework7/issues/3745

I don’t know if that could help, but hope so! If you make any progress, feel free to update the thread :slightly_smiling_face:

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona
Thanks for your recommendation. Unfortunately, I was not able to resolve these dependency issues. I ended up using another pre-configured Akeneo instance from ionos.com, which now worked without problems.

Thanks anyway for your help, very much appreciated.

Best regards,
Iwan

Hi @packraftch

I am sorry to hear you were not able to solve the problem :frowning:.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing to this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.