ERROR enabling Extra_Locales in docker-compose.yml

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?:
    image: ‘docker.io/bitnami/moodle:3-debian-10

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX):
    Linux Debian 10

  • Have you installed any plugin or modified any configuration file?:

  • Describe here your question/suggestion/issue (expected and actual results):

I added the Lines for Extra-locales as stated in the howto: https://hub.docker.com/r/bitnami/moodle/
to docker-compose.yml

moodle:

image: ‘bitnami/moodle:3’ # remove this line !

build:
context: .
dockerfile: Dockerfile
args:
- EXTRA_LOCALES=“fr_FR.UTF-8 UTF-8, de_DE.UTF-8 UTF-8, it_IT.UTF-8 UTF-8, es_ES.UTF-8 UTF-8”

when I execute docker-compose up I get this error:
ERROR: The Compose file ‘./docker-compose.yml’ is invalid because:
Unsupported config option for services.moodle: ‘args’
services.moodle.build contains an invalid type, it should be a string, or an object

  • Steps to reproduce the issue (if relevant):
    docker --version: 19.03.13, build 4484c46d9d
    docker-compose --version: 1.27.2, build 18f557f9

  • Copy the apache log (if relevant):

PASTE HERE

Hi @evanescent

Thank you very much for using Bitnami Moodle.

As this issue is specific to a container image, would you mind opening a new issue here?

https://github.com/bitnami/bitnami-docker-moodle/issues

Our team will be more than happy to provide you with assistance there. Chart and docker specific problems are usually handled in GitHub.

Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.