Error configuring Winlogbeat in windows 10 version 2004 (OS build 19041.685) (Error configurando Winlogbeat windows 10)

Keywords: ELK - Windows - How to - Other
Description:
I have bitnami-elk-7.10.1-0-linux-debian-10-x86_64-nami installed
Install the winlogbeat-7.10.1-windows-x86_64 client.
Next step configure winlogbeat.yml

output.elasticsearch:
  hosts: ["192.168.16.140:9200"]

setup.kibana:
  host: "192.168.16.140:5601"

In PowerShell, I test the configuration and it throws me the following.

PS C: \ winlogbeat>. \ Winlogbeat.exe test output
elasticsearch: http: //192.168.16.140: 9200 ...
  parse url ... OK
  connection ...
    parse host ... OK
    dns lookup ... OK
    addresses: 192.168.16.140
    dial up ... OK
  TLS ... WARN secure connection disabled
  talk to server ... ERROR Connection marked as failed because the onConnect callback failed: Winlogbeat requires the default distribution of Elasticsearch. Please update to the default distribution of Elasticsearch for full access to all free features, or switch to the OSS distribution of Winlogbeat.

Then I check Add Data / Windows Event Log and it returns the following result: No data has been received yet
On the server I opened ports 9200, 5601.
Could you guide me how to proceed correctly?
Regards.

############################################
Tengo instalado bitnami-elk-7.10.1-0-linux-debian-10-x86_64-nami
Instale el cliente winlogbeat-7.10.1-windows-x86_64.
Paso seguido configure winlogbeat.yml

output.elasticsearch:
  hosts: ["192.168.16.140:9200"]

setup.kibana:
  host: "192.168.16.140:5601"

En PowerShell, realizo el test de la configuracion y me arroja lo siguiente.

PS C:\winlogbeat> .\winlogbeat.exe test output
elasticsearch: http://192.168.16.140:9200...
  parse url... OK
  connection...
    parse host... OK
    dns lookup... OK
    addresses: 192.168.16.140
    dial up... OK
  TLS... WARN secure connection disabled
  talk to server... ERROR Connection marked as failed because the onConnect callback failed: Winlogbeat requires the default distribution of Elasticsearch. Please update to the default distribution of Elasticsearch for full access to all free features, or switch to the OSS distribution of Winlogbeat.

Luego verifico en Add Data / Windows Event Log y arroja el siguinete resultado: No data has been received yet
En el server abri los puerto 9200, 5601.
Pudieran orientarme como proceder correctamente?
Saludos.

Hello @arlenis0421

Let me share with you some previous similar cases:
https://community.bitnami.com/t/elk-7-0-0-with-filebeat-this-beat-requires-the-default-distribution-of-elasticsearch/67179/6


If they don’t help I would suggest you ask in the official forums to get more information about the different configuration parameters:

https://discuss.elastic.co/

Bitnami packages and configures already existing applications. However, we can only offer support and help on basic and most frequent application configurations. Always based on the default configuration or on our guides.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.