Error - bitnami redmine installaiton on Windows Server 2022

Keywords: Redmine - Installers - Technical issue - Application configuration

bndiagnostic ID: 60d44f35-b24d-8fab-4127-fe9b74487371

Description:
Hi,
After the instlatiton, it was working, i tried to chnage the url and remove redmine but we are getting an error below now

when we try to open redmine it shows “Page not found” but apache is working.
it seems to be some routing issues in some files


ActionController::RoutingError (No route matches [GET] “/redmine”):

actionpack (5.2.6) lib/action_dispatch/middleware/debug_exceptions.rb:65:in call' actionpack (5.2.6) lib/action_dispatch/middleware/show_exceptions.rb:33:in call’
railties (5.2.6) lib/rails/rack/logger.rb:38:in call_app' railties (5.2.6) lib/rails/rack/logger.rb:26:in block in call’
activesupport (5.2.6) lib/active_support/tagged_logging.rb:71:in block in tagged' activesupport (5.2.6) lib/active_support/tagged_logging.rb:28:in tagged’
activesupport (5.2.6) lib/active_support/tagged_logging.rb:71:in tagged' railties (5.2.6) lib/rails/rack/logger.rb:26:in call’
actionpack (5.2.6) lib/action_dispatch/middleware/remote_ip.rb:81:in call' request_store (1.5.0) lib/request_store/middleware.rb:19:in call’
actionpack (5.2.6) lib/action_dispatch/middleware/request_id.rb:27:in call' rack (2.2.3) lib/rack/method_override.rb:24:in call’
rack (2.2.3) lib/rack/runtime.rb:22:in call' activesupport (5.2.6) lib/active_support/cache/strategy/local_cache_middleware.rb:29:in call’
actionpack (5.2.6) lib/action_dispatch/middleware/executor.rb:14:in call' actionpack (5.2.6) lib/action_dispatch/middleware/static.rb:127:in call’
rack (2.2.3) lib/rack/sendfile.rb:110:in call' rack (2.2.3) lib/rack/content_length.rb:17:in call’
railties (5.2.6) lib/rails/engine.rb:524:in call' thin-1.8.0-x64 (mingw32) lib/thin/connection.rb:86:in block in pre_process’
thin-1.8.0-x64 (mingw32) lib/thin/connection.rb:84:in catch' thin-1.8.0-x64 (mingw32) lib/thin/connection.rb:84:in pre_process’
thin-1.8.0-x64 (mingw32) lib/thin/connection.rb:53:in process' thin-1.8.0-x64 (mingw32) lib/thin/connection.rb:39:in receive_data’
eventmachine-1.2.7-x64 (mingw32) lib/eventmachine.rb:195:in run_machine' eventmachine-1.2.7-x64 (mingw32) lib/eventmachine.rb:195:in run’
thin-1.8.0-x64 (mingw32) lib/thin/backends/base.rb:75:in start' thin-1.8.0-x64 (mingw32) lib/thin/server.rb:162:in start’
thin-1.8.0-x64 (mingw32) lib/thin/controllers/controller.rb:87:in start' thin-1.8.0-x64 (mingw32) lib/thin/runner.rb:203:in run_command’
thin-1.8.0-x64 (mingw32) lib/thin/runner.rb:159:in run!' thin-1.8.0-x64 (mingw32) bin/thin:6:in <top (required)>’
bin/thin:29:in load' bin/thin:29:in

Hi @sohailsoh,

What did you do to remove the “/redmine” alias? Did you use our bnconfig tool and the --appurl option?

https://docs.bitnami.com/installer/faq/linux-faq/configuration/understand-bnconfig/#supported-options

Hi Yes,
i used this in CMD ->
bnconfig tool and the --appurl option-

this is my httpd-prefix now

ProxyPass /redmine balancer://redminecluster
ProxyPassReverse /redmine balancer://redminecluster

<Proxy balancer://redminecluster>
BalancerMember http://127.0.0.1:3001/redmine
BalancerMember http://127.0.0.1:3002/redmine

Include “C:\Bitnami\redmine-4.2.3-3/apps/redmine/conf/httpd-app.conf”

Please can you support to resolve this issue.

I do not know why that file was not updated, can you edit it?

ProxyPass / balancer://redminecluster
ProxyPassReverse / balancer://redminecluster

<Proxy balancer://redminecluster>
    BalancerMember http://127.0.0.1:3001/
    BalancerMember http://127.0.0.1:3002/
</Proxy>

Include "C:\Bitnami\redmine-4.2.3-3/apps/redmine/conf/httpd-app.conf"

and restart Apache? Can you access Redmine now?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.