Error 503 Backend fetch failed after installing SMTP

Keywords: Magento - Google Cloud Platform - Technical issue - Email configuration (SMTP)
bnsupport ID: 52a06d3b-cfee-3a34-73a4-9bcf8c2b04cd
Backend fetch failed

Guru Meditation:

XID: 31
Varnish cache server.

support bundle: 52a06d3b-cfee-3a34-73a4-9bcf8c2b04cd

Hello @dailynaturalproduct,

Could you please take a look at our Debug Magento Errors guide and after executing the commands in it restart all the services with:

sudo /opt/bitnami/ restart

There is also some errors in your logs related to insufficient memory:

mmap() failed: [12] Cannot allocate memory
PHP Fatal error:  Out of memory (allocated 10485760) (tried to allocate 20480 bytes) in /bitnami/magento/vendor/magento/framework/Serialize/Serializer/Serialize.php on line 42
Mon May 17 03:43:09 2021 (16730): Fatal Error Insufficient shared memory!
Mon May 17 03:39:43 2021 (16795): Fatal Error Insufficient shared memory!

Please try increasing your instance’s memory. To do so, you can check this guide for more information.

Francisco de Paz

Increased memory but still same issue,

Please check below support ticket


Hello @dailynaturalproduct,

Did you restart your instance after increasing its memory? It seems all the services are up and running, did you enable SMTP using our Install The Magento Magepal SMTP Extension guide?

There is also an error in our logs regarding the tool that manages the start/stop of the instance’s services:

Control file '/etc/gonit/gonitrc' does not exists

Could you please follow the steps explained by my colleague in this thread: Control file '/etc/gonit/gonitrc' does not exists LAMP AWS

Francisco de Paz

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.