Domain is running on HTTPS but its showing not secured

khanabid11293@wordpress-1-fashionfactory-vm:~$ sudo /opt/bitnami/ctlscript.sh restart apache
Unmonitored apache
httpd.bin: Syntax error on line 562 of /opt/bitnami/apache2/conf/httpd.conf: Syntax error on line 69 of /opt/bitnam
i/apache2/conf/bitnami/bitnami.conf: without matching section
apache config test fails, aborting
httpd.bin: Syntax error on line 562 of /opt/bitnami/apache2/conf/httpd.conf: Syntax error on line 69 of /opt/bitnam
i/apache2/conf/bitnami/bitnami.conf: without matching section
apache config test fails, aborting
Monitored apache
khanabid11293@wordpress-1-fashionfactory-vm:~$

Please execute the bnsupport tool again so I see the current status of your apache config.

The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
c84448b2-d62d-a782-f948-6c67e265ce72

Hi @khanabid11293,

I don’t know what you did, but you have reintroduced all the syntax errors we have been fixing since the beginning of the thread.

Can you try using the below bitnami.conf file? It should work without any other modification:

# Default Virtual Host configuration.

<IfVersion < 2.3 >
  NameVirtualHost *:80
  NameVirtualHost *:443
</IfVersion>

<VirtualHost _default_:80>
  DocumentRoot "/opt/bitnami/apache2/htdocs"
  <Directory "/opt/bitnami/apache2/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    <IfVersion < 2.3 >
      Order allow,deny
      Allow from all
    </IfVersion>
    <IfVersion >= 2.3 >
      Require all granted
    </IfVersion>
  </Directory>

  # Error Documents
  ErrorDocument 503 /503.html

  # Bitnami applications installed with a prefix URL (default)
  Include "/opt/bitnami/apache2/conf/bitnami/bitnami-apps-prefix.conf"
</VirtualHost>

# Default SSL Virtual Host configuration.

<IfModule !ssl_module>
  LoadModule ssl_module modules/mod_ssl.so
</IfModule>

Listen 443
SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on
SSLCipherSuite "EECDH+ECDSA+AESGCM EECDH+aRSA+AESGCM EECDH+ECDSA+SHA384 EECDH+ECDSA+SHA256 EECDH+aRSA+SHA384 EECDH+aRSA+SHA256 EECDH !aNULL !eNULL !LOW !3DES !MD5 !EXP !PSK !SRP !DSS !EDH !RC4"
SSLPassPhraseDialog  builtin
SSLSessionCache "shmcb:/opt/bitnami/apache2/logs/ssl_scache(512000)"
SSLSessionCacheTimeout  300

<VirtualHost _default_:443>
  ServerName www.fashionfactoryshop.in
  ServerAlias www.fashionfactoryshop.in
  Redirect permanent / https://www.fashionfactoryshop.in/
  DocumentRoot "/opt/bitnami/apache2/htdocs"
  SSLEngine on
  SSLCertificateFile "/etc/letsencrypt/live/www.fashionfactoryshop.in/cert.pem"
  SSLCertificateKeyFile "/etc/letsencrypt/live/www.fashionfactoryshop.in/privkey.pem"
  SSLCertificateChainFile "/etc/letsencrypt/live/www.fashionfactoryshop.in/chain.pem"
  <Directory "/opt/bitnami/apache2/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    <IfVersion < 2.3 >
      Order allow,deny
      Allow from all
    </IfVersion>
    <IfVersion >= 2.3 >
      Require all granted
    </IfVersion>
  </Directory>

  # Error Documents
  ErrorDocument 503 /503.html

  # Bitnami applications installed with a prefix URL (default)
  Include "/opt/bitnami/apache2/conf/bitnami/bitnami-apps-prefix.conf"
</VirtualHost>

# Bitnami applications that uses virtual host configuration
Include "/opt/bitnami/apache2/conf/bitnami/bitnami-apps-vhosts.conf"

# Status
ExtendedStatus on
<VirtualHost _default_:80>
ServerName local-stackdriver-agent.stackdriver.com
<Location /server-status>
  SetHandler server-status
  Order deny,allow
  Deny from all
  Allow from 127.0.0.1
</Location>
</VirtualHost>

shall i put above text after deleting all previous entries in the file.

Exactly, you should replace the whole file

Hi i have done it and lock simble also coming but website is not opening see below wrror.

Sorry there was a mistake. Can you try with this one?

# Default Virtual Host configuration.

<IfVersion < 2.3 >
  NameVirtualHost *:80
  NameVirtualHost *:443
</IfVersion>

<VirtualHost _default_:80>
  DocumentRoot "/opt/bitnami/apache2/htdocs"
  <Directory "/opt/bitnami/apache2/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    <IfVersion < 2.3 >
      Order allow,deny
      Allow from all
    </IfVersion>
    <IfVersion >= 2.3 >
      Require all granted
    </IfVersion>
  </Directory>

  # Error Documents
  ErrorDocument 503 /503.html

  # Bitnami applications installed with a prefix URL (default)
  Include "/opt/bitnami/apache2/conf/bitnami/bitnami-apps-prefix.conf"
</VirtualHost>

# Default SSL Virtual Host configuration.

<IfModule !ssl_module>
  LoadModule ssl_module modules/mod_ssl.so
</IfModule>

Listen 443
SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on
SSLCipherSuite "EECDH+ECDSA+AESGCM EECDH+aRSA+AESGCM EECDH+ECDSA+SHA384 EECDH+ECDSA+SHA256 EECDH+aRSA+SHA384 EECDH+aRSA+SHA256 EECDH !aNULL !eNULL !LOW !3DES !MD5 !EXP !PSK !SRP !DSS !EDH !RC4"
SSLPassPhraseDialog  builtin
SSLSessionCache "shmcb:/opt/bitnami/apache2/logs/ssl_scache(512000)"
SSLSessionCacheTimeout  300

<VirtualHost _default_:443>
  ServerName fashionfactoryshop.in
  ServerAlias www.fashionfactoryshop.in
  DocumentRoot "/opt/bitnami/apache2/htdocs"
  SSLEngine on
  SSLCertificateFile "/etc/letsencrypt/live/www.fashionfactoryshop.in/cert.pem"
  SSLCertificateKeyFile "/etc/letsencrypt/live/www.fashionfactoryshop.in/privkey.pem"
  SSLCertificateChainFile "/etc/letsencrypt/live/www.fashionfactoryshop.in/chain.pem"
  <Directory "/opt/bitnami/apache2/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    <IfVersion < 2.3 >
      Order allow,deny
      Allow from all
    </IfVersion>
    <IfVersion >= 2.3 >
      Require all granted
    </IfVersion>
  </Directory>

  # Error Documents
  ErrorDocument 503 /503.html

  # Bitnami applications installed with a prefix URL (default)
  Include "/opt/bitnami/apache2/conf/bitnami/bitnami-apps-prefix.conf"
</VirtualHost>

# Bitnami applications that uses virtual host configuration
Include "/opt/bitnami/apache2/conf/bitnami/bitnami-apps-vhosts.conf"

# Status
ExtendedStatus on
<VirtualHost _default_:80>
ServerName local-stackdriver-agent.stackdriver.com
<Location /server-status>
  SetHandler server-status
  Order deny,allow
  Deny from all
  Allow from 127.0.0.1
</Location>
</VirtualHost>

Thanks a lot man finaly its working fine now

1 Like

I am glad it worked!! Please create other post if you find new issues

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.