Disk space is getting filled up rapidly!

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Application configuration

bnsupport ID: 1fce42e2-0c96-ef1b-5d94-3e8a8c2fdf8b

bndiagnostic output:

? Nginx: Found possible issues
? Resources: Found possible issues
? Mysql: Found possible issues
https://docs.bitnami.com/installer/infrastructure/nginx/troubleshooting/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mysql/

bndiagnostic failure reason: Other

Description:
Hello,
Don’t know why, But our free space in the disk is getting filled up pretty fast.
A few days ago it was 20 GB, We increased it to 25 GB, And within just 5-6 days it’s already 25 GB. This website is a news portal and we are hardly updating 4-5 news every day with some 3-5 images with less than 1 MB each.

Wanted to know how is the GBs of space are getting filled up so rapidly.
Could you please check and let us know?

Hi @vgnavada,

Thanks for using Bitnami. This error is usually caused by plugins using the database to store temporal data. All those database access create events that get logged in the binlog files, making them increase fast. According to the bndiagnostic data, this seems to be your case as well.

mysql/data:
total 4579220
drwxr-x---  7 mysql root        4096 Nov 25 07:11 .
drwxr-xr-x 11 root  root        4096 Jun 13  2020 ..
-rw-r-----  1 mysql root          56 Jun  1  2020 auto.cnf
-rw-r-----  1 mysql mysql        179 Aug 10 07:18 binlog.000091
-rw-r-----  1 mysql mysql 1073759447 Nov 19 04:44 binlog.000125
-rw-r-----  1 mysql mysql 1073887062 Nov 22 04:47 binlog.000126
-rw-r-----  1 mysql mysql 1073751535 Nov 23 13:08 binlog.000127
-rw-r-----  1 mysql mysql 1073820653 Nov 25 05:06 binlog.000128
-rw-r-----  1 mysql mysql  218984448 Nov 25 07:06 binlog.000129

You can check which plugins are causing the issues using the mysqlbinlog tool as explained in the official docs

https://dev.mysql.com/doc/refman/8.0/en/mysqlbinlog.html

Apart from that, I noticed you are using an old version of the bndiagnostic tool, can you download and install the latest version using the next guide?

https://docs.bitnami.com/general/how-to/understand-bndiagnostic/

Hi @gongomgra,

I tried this to update the bndiagnostic tool, It did not ask me to update anywhere:

I just get this output:

I also tried this:

I got this:
image

I’m not sure how to deal with it, I’m not so forward technically forward, Could you please educate me?

Hi @vgnavada

You can manually update the tool by following the steps described in the guide:

cd ~
wget -O bndiagnostic-linux-x64.run https://downloads.bitnami.com/files/bndiagnostic/latest/bndiagnostic-linux-x64.run
test ! -d "/opt/bitnami/bndiagnostic" && sudo mkdir /opt/bitnami/bndiagnostic
sudo mv bndiagnostic-linux-x64.run /opt/bitnami/bndiagnostic/
sudo chmod +x /opt/bitnami/bndiagnostic/bndiagnostic-linux-x64.run
sudo ln -sf /opt/bitnami/bndiagnostic/bndiagnostic-linux-x64.run /opt/bitnami/bndiagnostic-tool

I also tried this:
I got this:
I’m not sure how to deal with it, I’m not so forward technically forward, Could you please educate me?

It seems the mysqlbinlog tool is having trouble handling the default-character-set section of the /opt/bitnami/mysql/my.cnf file. Please, perform the following changes to the file and execute the tool again, the issue should be solved:

/opt/bitnami/mysql/my.cnf

...
[client]
port=3306
socket=/opt/bitnami/mysql/tmp/mysql.sock

- default-character-set=utf8mb4
+ #default-character-set=utf8mb4

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hello @jcarmona,
Thanks for the response.

I think I found out the issues. It was with the W3 TOTAL CACHE Plugin.
I purged the cache and uninstalled the plugin once in for all.

Now I have around 10GB of free space.
image

Hello @jcarmona ,
These steps are also done;

This is the output I got:


So this means the tool is updated to the lates version?