Disable apache service on startup

Keywords: NodeJS - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: df4bae71-6120-1c75-64a6-266dc1f5af9a

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I am attempting to disable the apache service so that I can handle certificates in code. However, even the most recent question (Disable apache auto start) I found failed to work. When running the solution found there, I get the below error.

mv: cannot stat '/opt/bitnami/apache/scripts/ctl.sh': No such file or directory

I cannot seem to find any documentation for this. Please help.

Hello @triplrrr,

Thanks for using our NodeJS stack! This stack uses an updated file structure, which is why the solution you shared doesn’t work for you. Could you please try the steps detailed by my colleague in the following thread:

Keep in mind that you will need to replace mariadb with apache.

Regards,
Francisco de Paz

This worked. This should be added to documentation, in an easily searchable location, as I spent hours looking for it prior to getting a response.

Hello @triplrrr,

I’m glad this worked! We will submit your suggestion to the documentation team so they can work on it, thanks for the feedback!

Regards,
Francisco de Paz

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.