Deploying Bitnami's CKAN template for Azure throws "InternalServerError" on Microsoft.DBforPostgreSQL/serverGroups

Keywords: General - Microsoft Azure - Technical issue - Other
Description:
Trying the CKAN template on Azure cloud with all the default configuration settings, repeatedly throws the same error “InternalServerError” on the resource “Microsoft.DBforPostgreSQL/serverGroups”. Deployment fails and the CKAN website is unavailable. No further log data is available.

Hi @ross.bohr

Thanks for using Bitnami CKAN!

I have tried to replicate your issue by creating a brand new MultiTier deployment of Bitnami CKAN 2.9.2 but could not face any issues. All the resources were successfully created:

What is the version of the template you are trying to launch? Could you please try deploying it again, just in case it was a transient error?

If the error persists, could you please click on Operation details to obtain further details on it?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

Thank you for the prompt reply!

I’m using " CKAN with Azure Database for PostgreSQL Hyperscale" template by Bitnami, version “CKAN 2.9.2-6-r01 (Debian 10)” . I have tried it 3 times today (in separate empty resource groups in West Europe in Azure cloud). Every time the same result - failing to deploy only the PostgreSQL resource - all others deploying fine but the web site becoming unavailable - Bad Gateway 502. All attempts were made with all default configuration settings, using passwords (not SSH keys).

I’ll give it another try now, in case this has been some transient Azure issue in West Europe.

KR
Ross

I’ll try it again now with these settings.

And again same results:

{
“status”: “Failed”,
“error”: {
“code”: “InternalServerError”,
“message”: “An unexpected error occured while processing the request. Tracking ID: ‘579b54ff-e792-4a6e-a33d-2a7b7d35ebc9’”
}
}

The above is only for the PostgreSQL resource. All others are fine

Hi @ross.bohr

Thanks for the detailed explanation, I have been able to reproduce your issue:

This is quite odd, as I have verified that the exact same deployment template can be deployed without problems in another region (I have tried East US). Setting it to West Europe makes PostgreSQL fail with the aforementioned error.

Initially, I thought the credentials you were providing included some special characters and the underlying issue was the lack of validation. Nevertheless, I have verified that the issue persists even if the provided passwords only use lowercase, uppercase & numbers.

Could you please try to deploy the solution using another region to validate my investigation?


Deployment in East US

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Thanks a lot , @jcarmona !

Your findings are correct - I just tested it today in “East US” region with all same default config settings and passwords and it deployed successfully and the web site is operational.

My pleasure @ross.bohr!

Just for the record, I gave it a try today at it seems to be working in West Europe again, so maybe it was a transient error after all :smile:

Screenshot 2021-05-12 at 17.00.17

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.