Database transfer from another computer

Keywords: Redmine - Windows - How to - Other
Description:
I have a backup file, I installed a new version. Even I try to change the ins directory name but the database folder is being created by the program automatically.

Sorry I dont know how to edit the first message.

I got my backup from bitnami_redmineplusagile 4.1.0-8. I installed on a new laptop redmine 4.1.0-9. Because some of the plugins doesn’t work in this version which I need. After succesfully install the program and the plugins and I uploaded the database using the following links.

https://docs.bitnami.com/installer/apps/redmine/administration/backup-restore-mysql-mariadb/

Especially during the uploading I used the “bitnami_redmine” name in the command. But nothing canged.

mysql -u root -p -D bitnami_redmine < backup_20200305.sql

The result as seen

I could see the folder as seen and it is not empty. How could I use this?
I foundsomething in the documentation but acc to my experience it seems heavy.


https://docs.bitnami.com/installer/apps/redmine/configuration/create-database/

I think this is possible but I couldn’t manage.

Is there anybody who may help and explain a little bit detailly?

Best regards, heathy days :mask:

Hi @kamilafacan,

We will continue woking with you on the other thread to avoid doing too many changes in the server at the same time. We will get back to this thread once the other one is closed.

Regards,
Gonzalo

Sorry @gongomgra

While the subject is different I thought that it is not correct to dscuss and search different subjects in one topic. If it is a problem I may close this topic and naturally you may… I don’t want to disturb anybody and I don’t have an intention like ignoring or not obeyin rules.

Again sorry.

Hi @kamilafacan,

Don’t worry, there’s no any problem on opening different threads for different issues. We think this is the right way of getting all your question solved. However, these two thread are kind of related, and we won’t get to a situation in which while trying to solve one issue, we modify and break something related to this question, and vice versa. Because of that, we will leave this thread open but on hold until we get a solution for your other question, and then we will continue working on this.

Hi @kamilafacan,

I think the Redmine+Agile database backup checks for the bitnami_redmineplusagile database existence and it creates it in case it is not present. What you can try is to import the entire bitnami_redmineplusagile database and then change the database name in the Redmine config file to start using the bitnami_redmineplusagile database instead of bitnami_redmine. Apart from that, and from your other thread, remember that migrating Redmine (or Redmine + plugins) requires to also migrate the plugins folder.

You can get more information about the migration process at https://docs.bitnami.com/installer/apps/redmine/administration/upgrade/

Hi @gongomgra

I will try this procedure especially to learn it. During this trials it is a little bit confusing in the documentation that I couldn’t find some commands. When I search if it is correct, sudo is a Linux command. Also I couldn’t find any file for the apache start.

Is it so or my installation is lack of some files or structure?

Your sincerely, healthy days

Hi @kamilafacan,

I thought that would be a more generic guide including the options for all the different Operating Systems, sorry. For Windows, you will need to stop/start/restart the services from the control manager as explained in the next guide instead of using the ctlscript.sh from the command line.

https://docs.bitnami.com/installer/apps/redmine/administration/control-services-windows/

For creating the “application backup” .tar.gz files you can stop the services and create a .zip file using the Windows builtin utilities as explained at https://support.microsoft.com/en-us/help/14200/windows-compress-uncompress-zip-files

For the rest of the commands (mysql, rake, etc.), you will need to use the Bitnami Console

https://docs.bitnami.com/installer/how-to/understand-bnconsole/

I tried this option a lot of times. It works very well. But everybody shall be very carefull and looked at the log files of compression program. If they reports some files can not be added due to their usage by another application, this means that your backup won’t work, no need to continue. Wait till all the servers stops comletely then you shall start the zip issue.

Thank you very much. This alternative acc to the computer speed tooks only half an hour.

Your sincerely

Hi @kamilafacan,

Yes, if any process is using a file, the zip process won’t work. Hope the migrate process worked for you.

Hello I found the way transferring.
For different installation like birnami_redmine and bitnami_redmineplusagile (for me) when you try to upload data from one to the other, mysql creates database with the original name (bitnami_redmineplusagile in bitnami_redmine). In this case bitnami redmine couldn’t reach the old database due to the name and folder.

Solution:
when you enter the redmine (127.0.0.1) you will the main page like. (I don’t know the oteer methods to reach phpMyAdmin) all steps written on the screenshots.
This method worked and I managed to turn from RedminePlusAgile to Redmine and to use the old database and structure.

Hope it works. ealthy days to everybody, thanks @gongomgra.

image
image
image


image

Hi @kamilafacan,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.