Ctlscript.sh failing

Keywords: WordPress + NGINX + SSL - Google Cloud Platform - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: 00288b24-29f2-cc05-8f2e-1f488ed4b47d

bndiagnostic output:

? Nginx: Found possible issues
? Php: Found possible issues
? Connectivity: Found possible issues
? Wordpress: Found possible issues
https://docs.bitnami.com/installer/infrastructure/nginx/troubleshooting/
https://docs.bitnami.com/general/apps/akeneo/administration/increase-memory-limit/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
when I run
sudo /opt/bitnami/ctlscript.sh start
I get the following output
Starting services…
Job for bitnami.service failed because the control process exited with error code.
See “systemctl status bitnami.service” and “journalctl -xe” for details.

turns out it was due to the Lets Encrypt SSL.
I had followed the method here
https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/
to generate and install lets encrypt certificate for NGINX wordpress install. It seems the auto SSL tools for the NGINX stack has been removed?

Something with this method was causing the ctlscript.sh command to fail.
I reverted back the server.crt.old and server.key.old and it would allow me to start services again.
I’ve migrated my site to an Apache wordpress setup and life is much easier…
I think I’ll give up on NGINX as the auto SSL tools for Apache are far superior, not to mention that the auto renew cronjob would fail about 80% of the time… hopefully auto renew works better in Apache.

Hi @nathan,

Thanks for your message and using Bitnami. You are right, the bncert-tool can’t update NGINX configuration at this moment. You can follow the alternative approach in our documentation to install and configure the SSL certificate with NGINX. The cronjob to update it is independent of the webserver used

https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#alternative-approach

Anyways I’m glad it worked for you using Apache. We will close this thread as solved. Do not hesitate to open a new thread in our forum with any other question you may have.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.