Container won't start bitnami/redmine:3.4.6-r3

Keywords: Redmine - Installers - How to - Services (Apache, MariaDB, MySQL…)

Description:
Im trying to migrate and update an older version of Redmine running on Windows Server to a container.

Here is my docker-compose.yaml

version: '3'
services:
  web:
    image: bitnami/redmine:3.4.6-r3
    restart: unless-stopped
    depends_on:
      - db
    ports:
      - 80:3000
    environment:
      REDMINE_DB_MYSQL: bitnami_redmine
      REDMINE_DB_PASSWORD: 8ksfJaL0dwQg40zugQ1ShzHlpilIQrBnBQwGZL6L
      REDMINE_SECRET_KEY_BASE: 8ksfJaL0dwQg40zugQ1ShzHlpilIQrBnBQwGZL6L
    volumes:
      #- redmine:/bitnami/redmine
      - bitnami:/bitnami
  db:
    image: mysql:5.6
    restart: unless-stopped
    environment:
      MYSQL_ROOT_PASSWORD: 8ksfJaL0dwQg40zugQ1ShzHlpilIQrBnBQwGZL6L
      MYSQL_DATABASE: bitnami_redmine
    volumes:
      - mysql:/var/lib/mysql

volumes:
  # redmine:
  mysql:
  bitnami:

After 7 minutes of inactivity I get this output

redmine-db-1   | Version: '5.6.51'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  MySQL Community Server (GPL)                                                           
redmine-web-1  | Error executing 'postInstallation': Failed to connect to bitnami_redmine:3306 after 36 tries  
redmine-web-1 exited with code 1                                                       
redmine-web-1  |                                                                                                                                                              
redmine-web-1  | Welcome to the Bitnami redmine container                                                                                                                     
redmine-web-1  | Subscribe to project updates by watching https://github.com/bitnami/bitnami-docker-redmine
redmine-web-1  | Submit issues and feature requests at https://github.com/bitnami/bitnami-docker-redmine/issues                                                               
redmine-web-1  |                                                                                                                                                              
redmine-web-1  | nami    INFO  Initializing redmine                                                                                                                           
redmine-web-1  | Error executing 'postInstallation': ELOOP: too many symbolic links encountered, lstat '/opt/bitnami/redmine/conf/configuration.yml'                          
redmine-web-1 exited with code 1                                                                                                                                              
redmine-web-1  | nami    INFO  Initializing redmine                                                                                                                           
redmine-web-1  | Error executing 'postInstallation': ELOOP: too many symbolic links encountered, lstat '/opt/bitnami/redmine/conf/configuration.yml'
redmine-web-1 exited with code 1                                                                                                                                              
redmine-web-1  | nami    INFO  Initializing redmine                             
redmine-web-1  | Error executing 'postInstallation': ELOOP: too many symbolic links encountered, lstat '/opt/bitnami/redmine/conf/configuration.yml'
redmine-web-1 exited with code 1

Hi @delany,

We provide technical support for our containers in our Github repositories. Our team is actively monitoring them and will be glad to help you there, usually within a business day, and the whole community will benefit from your contribution. Could you please post your question by creating a new issue in the redmine repo?

https://github.com/bitnami/bitnami-docker-redmine/issues

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.