ComfortUpdate fails because of modified files

Keywords: LimeSurvey - Amazon Web Services - Technical issue - Upgrade
Description:
Install Limesurvey on AWS.
Enable Remote Control (no idea of this is related)
Do comfort update.

Get an error saying :

The following files will be modified or deleted but were already modified by someone else.
These files will be backed up and then replaced by the update procedure.

/.htaccess
/application/config/config-defaults.php

Then there are only a Cancel and Check Again buttons.

Hi @bdrhoa,

We move all the information of the .htaccess files to a htaccess.conf file to improve the security and performance of the Apache server

https://docs.bitnami.com/aws/components/apache/#how-to-configure-htaccess-files

During the installation process, we set the config['sitename'] value in this file but we don’t modify any other line there, did you modify the file lately?

Please note that Bitnami packages and configures already existing applications. We can only offer support and help on basic and most frequent application configurations. Always based on the default configuration or on our guides.

If the issue is related to the application itself or any third party tool, probably someone with more experience and knowledge about that specific tool can help you better than we can. We suggest you to post your question on the official support forums of the application so others can help you with your issue.

https://www.limesurvey.org/forum

Do not hesitate to write us back if you have any other questions about the Bitnami solutions

No, I didn’t make any changes myself.

So, the ComfortUpdate feature doesn’t work or was never texted with Bitnami?

Is this a bug? If not, please document that ComfortUpdate doesn’t work.

Here’s the same question on the Limesurvey site.

Hi @bdrhoa,

I just tested the Comfortupdate plugin in Limesurvey and it worked properly after modifying the permissions of the installation folder. I launched a Bitnami Limesurvey 3.13.2 and ss you can see in the screenshots, I could start the process but got an error with the permissions

I needed to modify the permissions of the application’s files

sudo find /opt/bitnami/apps/limesurvey/htdocs/ -type f -exec chmod 664 {} \;
sudo find /opt/bitnami/apps/limesurvey/htdocs/ -type d -exec chmod 775 {} \;

And check clicked on “Check again”

After the upgrade process, I could log in to the application again and the application showed the new version

image

I also checked that the upgrade process creates several .htaccess files. As I mentioned, we moved the information from those files to the htaccess.conf file, you can do so by following our documentation. If you want to start using the .htaccess files, you can modify the AllowOverride option in the /opt/bitnami/apps/limesurvey/conf/httpd-app.conf file to “All”.

Happy to help!


Was my answer helpful? Click on :heart:

2 Likes

That works! Just for clarification is not necessary to start using .htaccess. Making the chmod changes is all that’s necessary.

Hi @bdrhoa,

You are right, but in case you want the application to use the new configuration of the .htaccess files, you will need to modify the AllowOverride option or move the information to the htaccess.conf file as I mentioned.

I’m glad to hear that it worked BTW :slight_smile:

And that’s why you don’t modify files of the external application. It will always bite you when there are little changes;

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.