Can't restart services after installing LetsEncrypt SSL

Keywords: WordPress - AWS - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: 03f0e042-c605-afbf-6897-91e06ede5440

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
? Resources: Found possible issues
? Processes: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I have been running bitnami Wordpress on AWS Lightsail for a few years now. Unfortunately I had to migrate to a new instance because the SSL certificate update wouldn’t authenticate due to PHP being out of date.

I spun up a new instance on AWS Lightsail and went through the process of using a LetsEncrypt certificate set. I used this tutorial (as I have done many times in the past when renewing the certificates):
https://lightsail.aws.amazon.com/ls/docs/en_us/articles/amazon-lightsail-using-lets-encrypt-certificates-with-wordpress

Under “Step 7: Create links to the Let’s Encrypt certificate files in the Apache server directory” of that tutorial, the very last step is to restart services.

Running this command:
sudo /opt/bitnami/ctlscript.sh start

Gives me this error:
Job for bitnami.service failed because the control process exited with error code.
See “systemctl status bitnami.service” and “journalctl -xe” for details.

I’ve tried repeatedly to re-run the process, including spinning up at least 3 different new instances and nothing has worked. These are completely fresh installs of bitnami wordpress on completely fresh instances.

Please help, I am just about out of patience as I have been dealing with this for at least 2 weeks, with my website completely unavailable.

Hi @mezwoodworks,

Can you launch a new instance and run the bncert tool following the same steps as described in this guide?

https://docs.bitnami.com/aws/how-to/understand-bncert/

After that, if it doesn’t work could you run the bndiagnostic tool again?

Regards,
Michiel

For anyone in the future using encountering the same problem I had using:
AWS Lightsail
Bitnami Wordpress install

DO NOT USE any other tutorial or instruction guide aside from the Bitnami Cert Tool one.

You can find the guide here:
https://docs.bitnami.com/aws/how-to/understand-bncert/

Thank you for your help on this community! I spun up a fresh instance, used the Bitnami Cert Tool guide linked above, and it worked.

1 Like